2 different bugs back to back

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: iustitia
  • What server/world did you experience your issue on: Yaxche
  • Describe the issue you are experiencing: first compass bug, then relogged to fix and no queue bug
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: i literally cannot play, absolutely ridiculous
  • (if a bug) Were you able to recover from the issue: NO
  • What are the steps to reproduce the issue as you experienced: just try to play the game

I FINALLY got in to play, did amrine one time. Then i lost all my tracking on compass. Apparently this is an on going issue since alpha there’s a ton of bug reports about it. So i relogged to attempt to fix, man what i mistake. I was placed at over 600 in queue. Then, after literally over an hour of waiting, i get to the front of queue. Window pops up and said failed to place in queue. WHAT THE HELL? Now i just had to restart queue again over 1000 this time. Like man, decent game but this is bullshit. Got to be able to play it. I get it you can’t fix everything right away but this has got to be one of the worst experiences of my life in a new game launch. Where can i go to ask for a refund

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.