3070 vsync limit usage

Using vsync will not allow gpu to 60fps and limits gpu usage to 85%. Unchecked vsync promotes screen tearing but allows 100% usage and hits 60fps.

Vsync limits the framerate to your monitors framerate.
If you have a 165Mhz monitor you will stress hard your gpu.

If you want to play +60 fps without tearing, try adding gsync/freesinc.

If problem persist and you want to play more than 60fps but do not stress hard you gpu you have two options:

  1. Lower your monitors refresh rate and activate the vsync from game.
  2. Go to Nvidia control panel, 3D apps, find the New World game and set max fps limit (check also if gsync is on). Disable vsync from game. (This for Nvidia gpu)

My screen is 144hz and when I have Vsync on I can’t go past 48 fps. As soon as I turn it off I reach my capped 60(usually locks at 62)

1 Like

Yeah so I’m playing at 4k 60hz and with vsync off I can hit capped 60fps. But can’t hit it with vsync on.

Exactly. It’s just that. Their Vsync isn’t working properly. Just turn it off for now

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.