Achievements and Titles disappeared

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: SaltTee Shaker
  • What server/world did you experience your issue on: Ygdrassil
  • Describe the issue you are experiencing: Achievements page is now empty as are my Titles
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Missing Achievements and Titles
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:

All of my achievements have disappeared from the Character (K) screen, achievements tab. Even when they were showing earlier(prior sesssion), they were not accurate (faction and 300 gear achievements were showing incomplete). Titles that I had earned before are all gone now as well…


short Workaround: you need to repair the game with Steam.

I got the same Problem, and it helps me.

I have also lost my Titles and Achievements. I tried the Steam repair, as admin, twice, with a reboot in between each attempt. Did not help. Steam still shows 56 Achievements, but nothing in-game.

Edit: I tried to remember what the last Title I got was, and I think it was The Strong Arm. (Hostile Takeover achievement) It is after I selected that title that they all disappeared. Interestingly, Steam thinks the last achievement I got was Quad Squad, which it says I got today, at apparently the time I got Hostile Takeover. I have had Quad Squad achievement for a few days, so it wasn’t today. Steam does not show Hostile Takeover in its list. Something must have gotten it’s wires crossed between the two achievements and that pooched the whole lot.

When I logged into the game today, the problem was gone. My Achievements and Titles were back. I don’t know what changed, but at least it corrected. I will keep an eye on it and if it happens again I’ll post again. :slight_smile:

Edit: And now they are gone again. :grimacing: I logged out for a while at lunch, then came back later and while playing I noticed that they were gone. Oh well. No clue what’s up, maybe they’ll come back again magically. :man_shrugging:

Mine are normally missing completely. There have been at least 2 times where they magically appeared either when I re-logged, or once right in the middle of a session when I was notified about “new achievements” while I was crafting (the achievements were unrelated to what I was doing). Even when they do appear, they are incomplete (ie: missing achievements for joining faction or equipping 300+ gear, etc)…

I think the Titles being empty are a secondary symptom and the missing achievements are the real root of the issue.

Steam shows that I have unlocked 17 in-game achievements so the game knew and reported them at some point…

This is still happening, and I don’t see it listed on the known issues list. Steam has stopped updating achievements at all it seems. I got the Char-Broiling achievement in-game, but Steam doesn’t show it.

So it seems that when I got an achievement in-game that Steam did not seem to recognize (the Hostile Takeover achievement isn’t on Steam’s list) the game and Steam then got out of sync and the problem of having achievements and titles disappear in-game began.

I wonder how many other in-game achievements are not in Steam’s list, and if others have seen this issue once they’ve gotten one of those.

I have the same problem, it gets better for a short time, then it gets corrupted again, steam file verification does not help.

Have you noticed if you got an achievement that Steam does not list? I wonder if the list of achievements the game tracks is different from what Steam has, and when you get one that isn’t in the Steam list it gets the game and Steam out of sync and causes issues.

It would also be nice to know if the devs are aware that there is an issue. But I haven’t seen any sign of that in the various threads dealing with this issue.

I guess it started after I got ‘everfall famous’ titles.

‘Everfall Famous-Reach a Territory Standing of 145’

I don’t see that on the Steam list. So maybe that does have something to do with it. I guess if they do end up looking into this issue there is a starting place, checking that Steam and NW have the same Achievements and stay in sync.

Well, still no fix for this, it’s still happening. I know it’s been reported by others, but it doesn’t seem to have gotten any traction. I guess it’s just one more bug to go in the ignore pile. Oh well, not a really big deal. Certainly won’t be the reason I stop playing, there are far too many other candidates for that crown. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.