Achievements still bugged

A month later and after the so called “bugfix” monthly update the whole problem still exists totally unchanged. Still have to relog up to 30 minutes every time I start the game or have to relog because of other bugs (from which not a single one was fixed too).

The march update didn’t fix anything. Still have to relog many times and when they are finally active, they are still displayed wrongly.

The databank issues seems to be even worse after the patch because now the achievements are displayed even more wrongly than before the patch.

Examples:

1 Like

You have been saying this for months. When will we get an actual progress update?

2 Likes

So bothersome having this problem still after all this time with them ‘bugfixing’ lots of stuff.

19/20 times there are no titles or achivements for me. It’s ridiculous.

Despite the patchnotes listing this as fixed there is no change at all in the behaviour of this bug. I still experience it everytime I start the game like described above.

After wasting 90 minutes relogging today (3 times 30+ min) I just found another part of this databank problem the games has. All my equipped items are not shown even though the character in the background is still equipped:

@Legumi I just got my next hickup with the system:

I just finished a mission achievement which is connected with a titel and a steam achievement. As it finished there was no pop up and no titel to accept. Since steam achievements only complete when the titel is accepted I also didn’t get that. Relogging didn’t change anything.

I had the same problem in the first week of release when my first house achievement behaved exactly the same. Months later it popped up when I bought my third house and the third house achievement got completed.

No change from todays patch @Legumi. Also posted in the mega bug thread again. The emptiness is still there when starting the game.

1 Like

I am having this issue still as well. But now, it is spilling over to the Invasion ranking page as well. In fact, the last time this happened, I didn’t even get the invasion reward box :frowning:

I can’t seem to get it working now at all. I have rebooted, verified game files, and still it shows this.

After day’s/ weeks of this issue, *Fixed (again), maybe due to this post/ else did achieve 2 new ones where only one showed up, then >1h ingame the update suddenly appeared ingame (and on steam)

What is your character name in New World: Helplessss
What server/world did you experience your issue on: Vega

I have tried logging out in far far away places away from Towns and it seemed to help. I would load in game and everything is there as it should… just sucks to have to login/logout in far way spots :frowning:

But then yesterday that went out the window…

I logged in and everything was all messed up again, no achievements, no title, assuming I will have no leader-board after invasion I was going to. So I exited to main login screen, back in, still messed up, Exited game completely, reloaded character, still messed up. Exited game again, reloaded character again, still messed up. I did this 3x and finally I got my information to load.

Now I see you are launching an update 1.4.4 but no mention of a fix for this? :roll_eyes:

All we get from AGS is that they are looking at this. In my case, in the afternoon and evenings, they disappear and never to appear no matter what I do - all the supposed fixes, Steam validation, admin rights, uninstall NW, uninstall Steam, etc etc etc.

But in the morning, they are there?!?!?!?!?1

WTF is this bug EVER going to be fixed? If it is a Steam client issue WHY CAN’T AGS GET STEAM to fix it or get rid of the Steam platform all together?!??!?!

From my observations since the betas I think the main problems are the places where the data of the character are stored and the loading into the game from there because besides achievements and titels it also includes sometimes other stuff like zoneboni and equipment. And if they finally load they often are not really shown correctly like the destinations achievements.

On top of that the whole problem gets worse when the loading of the server into the client gets more difficult. Since the last merger the cities on my server have extreme lag as you enter and load only glacial. When logging in inside a city and relogging in there, it is nearly impossible to get everything working. Only outside far away in the boondocks I get it to work.

10 Months since closed beta (since then I have it everytime I start the game) and all they could come up with was a reskin (uninitialized/88 → empty) and a few empty phrases in patchnotes (which did nothing at all). I just hope it is not a problem with their overly broken engine that they can’t fix.

I’ve been to all settlements and they’re all “visited” but still showing 16/17


Hello,
I’m currently having an issue where i’ve reached 200 rank in Tannery but my steam achievement has not unlocked - i reached level 200 more than three days ago.

I have tried verifying game files on steam as well as creating a new character in a different region and the achievement is still not unlocked on steam.

  • What is your character name in New World: Oedon Writhe
  • What server/world did you experience your issue on: Yggdrasil
  • Describe the issue you are experiencing: I’m amassing quite a list of completed achievements that haven’t popped on steam.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Achievements are not completing on Steam.
  • (if a bug) Were you able to recover from the issue: No
  • What are the steps to reproduce the issue as you experienced: I’ve no way to reproduce the issue, but I have taken steps to try to fix it, such as logging in and out completely, creating a new character on different regions, and validating files on steam.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

sooo, are the New World devs still not giving a single heck about this issue?

1 Like

I’m having this issue too!

Try asking why ALL these bugs from BETA are still in game LMMFAO…you’ll get a blow off response “We’re looking into it” or “We’ll/I’ll pass this along to the Devs” or most truthful answer…no answer at all

1 Like