After patching it wont launch!

the game wont launch after todays patch
Failed to start the game (2)

Same, had this issue w/ the PTR and never was able to play on PTR. Sad to see this made it into the live game as well. Game starts up, but just hangs at the first loading screen. No crash message or anything, just doesn’t ever go past it.

From what I can tell, the servers are still down for Maintenance.

2 Likes

I was able to launch the game client during the maintenance window, it would load in and display my characters etc, but wouldn’t let me log in to a server w/ a maintenance message. After the latest Steam update to the game client, I can’t launch the game at all.

Have you tried to do a file verification?

Try updating your graphics card. I had the same problem and updating the graphics card fixed it.

Check to see if this helps, I had a similar issue. Check out my post on my solution. If it helps just leave a like please so more can see it. It doesn’t seem to be as common of an issue as some so I’d like people to be able to find it if it proves to help more than just me!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.