Amber Gems STILL not Scaling to Focus but not listed in known bugs

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Azrial Tide

  • What server/world did you experience your issue on: Themiscyra

  • Describe the issue you are experiencing: Amber gems not scaling damage

  • Is this a bug or an exploit: Major Bug

  • (if a bug) How did the issue effect your gameplay: Cant do damage except with lifestaff

  • (if a bug) Were you able to recover from the issue: Nope for 2 patches now

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: Socket amber gem into spear

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.