Asmodeum craft: Cooldown Threshold 4294967286 (!?)

  • What is your character name in New World: DarXyde

  • What server/world did you experience your issue on: Hellheim

  • Describe the issue you are experiencing: Tried to craft Asmodeum, it didn’t craft, it didn’t show the “Crafting Failed”, but just kicked me out of the crafting menu. When went back in, i got the error in the screenshot. It still shows as craftable, but “CAN’T CRAFT” on the crafting button.

  • Is this a bug or an exploit: Clearly a bug.

  • (if a bug) How did the issue effect your gameplay: Can’t craft the “daily” Asmodeum, so affects my economy.

  • (if a bug) Were you able to recover from the issue: Tried changing cities, can’t afford relogging (because of the long queue). So, no.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:


  • What are the steps to reproduce the issue as you experienced: Just craft… Asmodeum?

Is somewhat similar to other reported issues where the cooldown started without producing the items, but in this case is not even in cooldown, so what can I do??!!

EDIT: relogging (much much later due to the queues) did fix the issue and was able to craft them.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.