Baetylus headpiece (lazarus quest) bugged!

  • What is your character name in New World: kayleoss

  • What server/world did you experience your issue on: Calgonor

  • Describe the issue you are experiencing:
    I have run the Lazarus dungeon TWICE! Each time paying money and lost my own orb to run it. Both times the quest did not complete. It is stuck at “Venture into the Lazarus…” and will not progress. Can I get my orb back since it bugged out twice

  • Is this a bug or an exploit: BUG

  • (if a bug) How did the issue effect your gameplay: Read above

  • (if a bug) Were you able to recover from the issue: NO

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
    Screenshot 2021-12-21 185007

  • What are the steps to reproduce the issue as you experienced: go to laz and do it, confirm that quest is still stuck at “Venture into Laz…”

3 Likes

Happening to me aswell, quest won’t update when entering the dungeon. Impossible to complete.

Same here… Quest could not be completed. And guess what still no response from AGS. Also i wonder if AGS knows how much it cost to enter dungeon.

Same here.

Some info i can add:

  • Tried with my own key
  • Tried with a key from a party member
  • Tried resetting the quest

i don’t care about the key, I do only want to finish the quest.

Thank you

Same here. Bump.

done the expedition 3 times now and still nothing… feelsbadman

I have ran this many times and even have tried to reset the quest. It will not update when I enter Laz. I would like to be able to complete this quest.

same here, did it 4 times and nothing.

Server: Brittia
Character Name: Arica

Really need a @Developer reply about it

I’ve also encountered the same bug and know of another in the same situation who’s also run Laz multiple times with the quest not being completable.

Same problem, can’t do the quest.
I’ve run the dungeon multiple times with different keys, I’ve repaired files, restarted the game, reset the quest but nothing works.

Hoping for a fix

Same issue. i want to be able to complete this quest. Only quest in game where it wont complete. This will almost be the final quest I have left to do BUT the game won’t let me complete it??

after countless runs and many attempts to get it to trigger, its bugged.

bump

  • TopherF
  • Completed Lazarus for the 2nd time quest never completed
  • 05/01/22 around 00:00-1am uk
  • Balanjar
  • Lazarus dungeon
  • Used my orb I got from quest first time on the day of the merge the quest never completed then did a second run today and same again the quest is outstanding dispute saying leave the dungeon to complete then go speak to npc.

Followed the quest steps on screen each time.

BUMP!
Can we have a fix?

@Luxendra @NW_Mugsy @Community-Team Can we get an update on this? Still can’t compete.
Also, if you reset can you get another orb?

I’ve forwarded this to the team but I’m sorry, I don’t have any updates at this time.

Have the same issue.

Thank you for ensuring they attend to the issue, bugged quests are more important than new GS bumps :slight_smile:

1 Like

Thanks

same here