Baetylus Headpiece

Baetylus Headpiece (Expedition)
There was a problem, passed the quest lazarus all according to the requirements and the item did not work.

Hello @yaroslav.andreichuk;

I’m really sorry with the problem that you have with this item.

Right now you can try to verify integrity of game files

*To learn how to verify your game files, go to this link: Steam Support :: Verify Integrity of Game Files

If non of this works please let me know so that I can escalate this issue.

Also I will need you to explain the issue a bit further and please send me the name of the item that did not work so that we can investigate further.

Thanks for the report and enjoy your holidays!

I also had that problem with this quest Baetlyus Headpiece Expedition. I used my Lazarus orb to enter the expedition like it said, and it registered that I entered, but did not get the item drop I needed from the boss to complete the quest. I reset the quest, and ran this again on another lazarus orb, and it did not even register that I entered the expedition. Wasted 2 orbs trying to complete this quest and it didn’t even work

Defeat the Cilla in the Lazarus Instrumentality Expedition and Collect the Naga Headdress. Then report back to Warden Reese in Shattered Mountain.

The task to go into the dungeon, when the quest came does not show that you are in the dungeon and then requires you to go, after when you kill a Cilla therяe is no item

This is the exact same issue I had

I have the same problem with this quest. Have ran Laz probably 5 or 6 times still with no completion. Have had no problems with any other expedition quest. Would love to see this quest fixed and orbs redistributed again or one time reduced crafting cost.

A lot of orbs and resources and resources have been spent, I did this quest 15 times !!!

6 times here and had the same issue…

Correct the quest and return the number of orbs lazarus how many times did the quest. Thank you
My nick ajjs2 Rocabara

Hello everyone, how are you, what decision was made?

A lot of people are having issues with this quest completing. Is there a developer response anywhere in regards to this problem of the quest not completing? I see there are numerous topics made on this subject, when can this be solved for us players?

developers are on vacation and when they are back they are busy looking for spelling mistakes in the new quests.

We are not a priority

Having the same issue. Have run this a number of times and wastes a ton of time/materials. This is the issue you run into when you start locking out dungeons with key requirements and players who are bugged can’t progress!

Kelthuzad the quest CAN NOT BE COMPLETE it does not drop the headpiece so you can not complete the quest it does not recognize that you enter the place and no its not me multiple people have this issue and yes I have tried reseting it and it does not work (please don’t be like blizzard and fix your game and Don’t blame the players)

Yesterday I tried to do it again, it doesn’t work, it doesn’t help

Run it 3-4 times and no headdress. I have used both orbs given to me. Will you be reimbursing us for these?

Dev Amazon, check quest and return orbs used when no working

Also had this problem. Wasted 2 expensive orbs trying to finish this quest.

Hello Travelers, :slight_smile:

Greetings!

I am sorry about the issue you all are experiencing with the Baetylus Headpiece (Expedition) .

Reading the comments on this post, I understand that the expedition isn’t registering the player’s entry,while the orb also gets consumed, and the drop from the boss is unavailable.

I will escalate this, for which I would require more information -
1.Charcter name:
2.Server name:
3.No. of times attempted for expedition:
4.Approx date when you first noticed the bug.
5.In game logs
6.dxdiag report

The instructions for generating a DXdiag can be found in this link: Open and run DxDiag.exe

While these are the instructions for finding the in-game logs:

  1. Press Windows+R on the keyboard, type %appdata% and press enter.
  2. Open the most recent file from this folder: /AppData/local/AGS/LogBackups.
  3. Paste the contents of the file into a .txt file.

Share these details with me on PM.

With this information, we’ll be able to investigate the issue further.

Cheers! :slight_smile: :evergreen_tree: :sunflower:

  1. ajjs2
    2.Rocabara
  2. ~15
  3. December 2021
2 Likes