Baring Teeth Quest fails

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Frank Bullitt
  • What server/world did you experience your issue on: Camelot, US West
  • Describe the issue you are experiencing: “Barring Teeth Quest” unable to apply the wolf musk, it displays Saltpeter? Won’t allow me to apply musk after the saltpeter is picked up. I set camp nearby as required, got the musk, but it never allows me to apply. Reset several times. Also I’m not the only one others are also having the same problem with the quest.
  • Is this a bug or an exploit:
  • (if a bug) How did the issue effect your gameplay: unable to continue main quest
  • (if a bug) Were you able to recover from the issue: no, still not working
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: not able to save screenshot, but this appears to be a common problem with this quest.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.