Barkimedies not giving quests

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Test Illy

  • What server/world did you experience your issue on: US/West Camelot

  • Describe the issue you are experiencing: I and several of my company mates are unable to get the Barkimedies Quests to activate. We’ve done all the quests that needed to be done before the new player experience update and he won’t give us the quests. We’ve done all the quests in Monarch’s Bluff, Windsward and Everfall, and he won’t give it to us. We’ve tried it on multiple characters on Multiple servers.

  • Is this a bug? (If this is an exploit, please follow the steps here: [Dev Blog] How to Report Exploits - Updated)

  • (if a bug) How did the issue affect your gameplay: This is removing a leveling option for the early levels

  • (if a bug) Were you able to recover from the issue:

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: We have leveled multiple characters trying to get the npc to give the quest and unable to reproduce the effects to get the dog to give the quests

  • When did this happen? (Date and Relative time; please include your timezone)

The Barkimedes quests are currently disabled right now.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.