Block Trade Invites stuck in the "on" position (default)

Whenever I log into the game, “Block Trade Invites” is always turned on. I can manually reset it to off, but when I log out – it turns itself back on. I have to manually reset it in Settings > Social every time I log into the game.

  • What is your character name in New World: Rohne / Rohne Reborn
  • What server/world did you experience your issue on: Heliopolis / Amarah
  • Describe the issue you are experiencing: Every time I log in I have to go into my options and enable trading because the game sets it to decline all trades every time I log out
  • Is this a bug? (If this is an exploit, please follow the steps here: [Dev Blog] How to Report Exploits - Updated) yes, it’s a bug
  • (if a bug) How did the issue affect your gameplay: I have to change my options every time I restart the game because it turns off my trading ability automatically. And when I finish adjusting the settings, it won’t save the new setting. It defaults back to “Block Trade Invites” after I log out of the game.
  • (if a bug) Were you able to recover from the issue: No, it has been going on for months
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
  • When did this happen? a few more months ago

I thought this would have been fixed a while ago, but it keeps persisting and its getting very annoying. My initial report has closed but the problem still persists. So I’m filing a new report so that issue gets fixed (soon).

  • What is your character name in New World:
  • What server/world did you experience your issue on:
  • Describe the issue you are experiencing:
  • Is this a bug? (If this is an exploit, please follow the steps here: [Dev Blog] How to Report Exploits - Updated)
  • (if a bug) How did the issue affect your gameplay:
  • (if a bug) Were you able to recover from the issue:
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
  • When did this happen? (Date and Relative time; please include your timezone)

bump

Still an issue.

Have you tried this before?
Open C:\Users\CHANGEME\AppData\Local\AGS and delete everything in that folder, then verify your game files after?

Hello and thank you for reporting this issue!

I’m sorry that your trade settings reset. I have forwarded this bug to the Dev team to review.

Has there been an update on this issue, yet? Its still broken.

Again checking to see if there has been any updates on this issue. It is still broken.

The issue I’m reporting does not appear in the “Known Issues” list.

My wife and I are having the same issue. It also looks like someone else reported it here, but the post was automatically closed after 21 days.

1 Like