Bought food from TP (Trading Post) but didn't get them

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Qhuet
  • What server/world did you experience your issue on: Midgard EU
  • Describe the issue you are experiencing: Bought tier 5 mining food from TP but did not recieve them, so lost pretty much gold. This happend from the Cutlass Keys TP, not sure if that has anything to do with it since i haven’t tried from any other TP as of writing this report
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Didn’t get my mining luck buff but lost the gold
  • (if a bug) Were you able to recover from the issue: Tried relog and restart the game, didn’t help. Thought they might just be invisable in bags but they are completely gone
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: I tried buying more but with the same result

I’ve now tried at several Trading Posts and can confirm that I do not recieve any tier 5 mining luck food, it states that i recieve it when buying but when opening bag they are not there.

Nothing gamebreaking per-say, but it’s alot of wasted gold - which is just annoying.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.