Brimstone sands quest line disappeared

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: gansosx
  • What server/world did you experience your issue on: Devaloka
  • Describe the issue you are experiencing: Brimstone sands questline disappeared before brimston under siege, i finished the one before it and nothing somes up after that
  • Is this a bug? (If this is an exploit, please follow the steps here: [Dev Blog] How to Report Exploits - Updated)
  • (if a bug) How did the issue affect your gameplay: Stopped
  • (if a bug) Were you able to recover from the issue: No
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:
  • When did this happen? (Date and Relative time; please include your timezone)
    Now
1 Like

Did you complete the Main Story Quest “A Selfless Nature” in Edengrove? That quest is a pre-requisite for the Main Story quest series in Brimstone.

My apologies, not trying to hijack with my question.

Do you have to be in a faction to complete the quest? I only got the entry quest and featherbane in BS. Thx

No, there’s an option for those without a faction!

It’s the same exact problem for me we did selfless nature. Staring at Ghazi Laghmani now after turning the quest in to Buhawi Manabat. I can NOT continue the main quest or the game can anyone help me???

2 Likes

I am having the exact same problem with Ghazi… So can’t continue with all my friends that the quest all worked for…

I also have some armour skins missing now of my favorite gear…

I don’t know what to do!

same for me. no way of doing anything in brimstone untill fix.
game name is motoori
server tartarus
its a game braking bug so help asap please

You are definitely right @Aenwyn. My quests are all missing in Brimstone sands too. The reason is just my main story “A selfless Nature” is bugged and dissappeared for ONE YEAR. For now, I only own the T4 staff. This is a big issue, the direct consquence is that we can not unlock the heartgem slot. It’s really sad. Pls do something to solve this problem. Seehttps://forums.newworld.com/t/main-story-misssing-a-selfess-nature/758923/6

1 Like


no brimstone under siege quest.bit of a game breaker.

i have the same problem after completing quest A Selfless Nature the NPC he disappeared and didn’t give me the quest Shattered Mountain



@Aenwyn

Yes i completed it

I have the same problem, got into brimstone sands did the first quest to lead to the first outpost and then nothing. all main questlines have disappeared and no quests in brimstone sands.

Same here. I cannot access the ‘A Selfless Nature’ quest.
Apparently we have to do this quest first before Buhawi Manabat will unlock the quest for the runestone unlock quest.

Is the ‘Selfless Nature’ quest bugged and no longer given by Adiana Theron? Ive completed all the quests in Edengrove can still nothing offered by Adiana for the ‘A Selfless Nature’ quest.

This is a major bug that needs to be fix as the Runegem cannot be accessed.

In fact, i think its dumb they make us complete a quest to use the Runegem. Should be automatically unlocked when you find a Runegem (as i have 8 in my bag and unable to use them).

Fix this Amazon!

same here. what the actual.

Server : DELOS
Character : Wild Honey