Buf with undiscardable quest items

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Argylas
  • What server/world did you experience your issue on: Asgard
  • Describe the issue you are experiencing: I accidentally picked up some quest items for the legendary quest weapons from a storage and now can’t put them back in. I also can’t salvage them, cant’ discard them and can’t reset/disband the quests. Now I’m stuck with theses items (which have weight) in my inventory.
  • Is this a bug? (If this is an exploit, please dm Aenwyn or Luxendra) Bug
  • (if a bug) How did the issue effect your gameplay: It takes storage capacity from my character.
  • (if a bug) Were you able to recover from the issue: No.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: NW Bug - Album on Imgur
  • What are the steps to reproduce the issue as you experienced: Don’t know. Just accidentally picked up the quest items from a storage. Before you could move them to a storage without problems.
  • When did this happen? (Date and Relative time; please include your timezone) 07.10 around 19 CET.

Hi there! This is being worked on. Thanks a bunch for reporting this however.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.