[Bug] Syndicate faction quest in Shattered Mountains

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World:

  • What server/world did you experience your issue on:

  • Describe the issue you are experiencing:
    Syndicate faction quest in Shattered Mountains, Mountainhome Outpost, from faction guy named Quon Teo. I’am unable to turn in completed faction quests:

Purge: Iratus
Purge: Spilaio Cavern

  • Is this a bug or an exploit:

  • (if a bug) How did the issue effect your gameplay:
    I can’t turn the faction quest in, even though i have completed. Therefore the issue is i will lose out on faction tokens and gold.

  • (if a bug) Were you able to recover from the issue:
    I tried relogging. Doesn’t seem to work.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced:
    I guess go to Shattered Mountains, Mountainhome Outpost and get the 2 faction quests and after completed them, you can’t turn them in.

I confirm, i have this issue as well. Yesterday i abandonded them, thinking it was due to maintenance, but today I have the same issue.


I dont know what happened. But after the maintenance yesterday for AH fix. I logged on and I could suddenly turn in the quests. Really weird.

Im sorry to hear you also had problems. I havent tried again afterwards to do the faction quests again to see if its bugging out again.

Sucks that other quests all bugs out for you :frowning: i guess we are not suppose to do faction quests in SM as syndicates :poop:

I got the same issue on Silpium, Marauder faction.

At least another person on the server has the same issue (that i know of), makes completing the 3 elite daily quests for decent gold quite a nuisance.

This issue only started appearing, after the latest Maintenance that fixed the AH issues.

Faction Quests work just fine in Reekwater and the other areas for me.

I had the same thing happen, and then go away, and now its back! :frowning:

This bug is still going through the Winter thingy patch @Luxendra @Zin_Ramu @Tosch @Kay
It’s kinda annoying cause when you want to stack your daily bonus with elite quest you lose 700 coins for every day you cannot do this. It’s been a while…

1 Like

had same issue with Marauder quest at great cleave since winter patch

Have same case with Covenant faction quest at SM. Also posted a report on this almost 2 weeks ago and I haven’t received any response. The fact that the bug keeps happening to a lot of people clearly shows that it’s an in game problem and this is still persist even after their most recent patch the other day. I’ve stopped doing faction at the moment because I don’t want to waste my time and effort going all around the map just to end up not being able to complete them because of this issue. Really disappointing.

I have this issue in multiple areas. Amazon gonna let me increase my area standing in their game or what? Not to mention the recommended way to ensure you can pay housing taxes… It’s been over a month of reporting this new issue caused by a patch.

I think it’s not letting us turn it in because our faction points are capped. I was doing fine until mine capped, and now I can’t turn in any regular faction quests.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.