Bug with main questline

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Avaynea
  • What server/world did you experience your issue on: hellheim
  • Describe the issue you are experiencing: unable to progress main questline. The quest “keeping it simple” cannot be completed
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: cannot progress the game
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: unable to screenshot
  • What are the steps to reproduce the issue as you experienced: I completed all quest steps and made the sword but quest giver does not have option to hand back in. I’ve tried resetting and doing again but I have the same issue

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.