Bug with Trading Post?

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the [Known Issues List] to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find [here]

  • What is your character name in New World: Oberon T’Angelus and Aeluin Veles (Fiances Character)

  • What server/world did you experience your issue on: Ohonoo

  • Describe the issue you are experiencing: Both of us are seeing level 60 gear in the Trading Post, however we are both only level 56 and 57 currently, We both do also have “Can Equip” selected., We did a test to see if it was just a visual bug but when purchased it says we are unable to equip the items assuming due to the level difference, HOWEVER with can equip unselected it shows me level 60 items that are legendary grade when i am still level 56. We have tried logging out and back in, and restarting the game, neither worked, we got off last night with this issue and logged back on and the issue is still persisting. I attached pictures for reference

  • Is this a bug or an exploit: bug

  • (if a bug) How did the issue effect your gameplay: it is making it near impossible to navigate the trading post

  • (if a bug) Were you able to recover from the issue: no

  • (if a bug) Please include a screenshot or video of the issue that you have experienced: Yes

  • What are the steps to reproduce the issue as you experienced: Be level 55 or 56 and look at trading posts

  • When did this happen? 7/4/2022 1:00AM EST - Current ( 11am EST)

Thank you for reporting this! We are currently working on fixing this experience in the Trading Post!


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.