Bugged GS on JewelCrafting

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Killyax Aysel
  • What server/world did you experience your issue on: Mardi
  • Describe the issue you are experiencing:
    So today I wanted to test how buffs worked on endgame jewel crafting
    This numbers are calculated on an asmodeum jewel, best mats
    I tried applying buffs 1 at a time
    554-570 Nothing on me
    564-580 With Jewelcrafter armor set (+10 Quality) all good so far
    569-585 with armor and earring, which is supposed to add 5 only to min gear score but it added to both? text bug on the description or visual bug and it is in reality 569-580?
    584-600 adding food to the previous, so +15, all good (unless previous step was supposed to stay at 580, then here should’ve been 584-595)
    And here the weird stuff starts, I wanted to check if trophies (Tier 1) worked properly/were already applied and I removed 1

With 1 Removed Trophy 587-600 (ehm, wtf?)
With 2 Removed Trophies 590-600 (ehm, wtf? pt2)
Then I decided to re add trophies
Re-adding 1, it went up to 593-600
Re-adding the other, it went to 596-600
Then for the sake of testing I went to my third house and removed and reapplied the last trophy, which gave a +3 when removed and another +3 when re-added and we reached 600-600

Crafted Result: 587
So trophies are bugged and we got that, but were they already applied before and caused a visual bug when I removed and readded them?
It’s fair to assume that the last correct GS number was 584-600 from the step where I added the +15 food.

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: Yes, I have to hope i manually calculate correctly what I’m about to craft

  • (if a bug) Were you able to recover from the issue: No

  • (if a bug) Please include a screenshot or video of the issue that you have experienced: I forgot to take screenshots or record the entire process (No more asmodeum, can’t test again until tomorrow), the only screenshot I have is the final crafted result

  • What are the steps to reproduce the issue as you experienced: As I said in the description, I simply applied 1 buff at a time, and to reproduce the trophy bug just remove them from your house and put them back on

Its bugged completely, tested today and it was 581-597 with all set+food+trophyes and 586-602 with only earring.
Then I crafted actual asmodeum setting and chain instead of only picking them from possible items and it went to 606-622 ><
But the item I crafted wasn’t this high GS obviously, it was 591.!


NewWorld_fZAUaQO6lh

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.