[BUG(train)] Missing textures bug, into another session bug, into new world logo stuck bug

  • What is your character name in New World: dabebi
  • What server/world did you experience your issue on: Mayda
  • Describe the issue you are experiencing: It takes me 30 minutes to play the game after teleporting.

it always goes something like this:

  1. After fast traveling half of the things doesnt load and i cant use storage in the cities
  2. to fix this i log out of the game
  3. Account logged from another session bug pops up
  4. only fix that works for me is uninstall easy anti cheat and verifying in the game file (takes around 10-15 mins)
  5. I try to log back to the game
  6. game stuck on new world logo screen
  7. only fix that works for me is reinstalling graphics driver (another 10 minutes wasted)
  8. I log back to the game, play in current location till i have to tp again.
  9. REPEAT :slight_smile:

BTW this makes me unable to join wars cuz i cant fix everything between war invite accept and war start (15min)

30 min every single time i have to fast travel somewhere till the game is playable

  • Is this a bug or an exploit: 3 BUGS
  • (if a bug) How did the issue effect your gameplay: Im wasting like 3 hours every day and i cant join any war/invasion
  • (if a bug) Were you able to recover from the issue: …
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: Imgur: The magic of the Internet
  • What are the steps to reproduce the issue as you experienced: I just teleport or try to login to the game to experience all of them

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.