Camp wont upgrade past t4 all quests copleted

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Helheim
  • What server/world did you experience your issue on: juiyuan
  • Describe the issue you are experiencing: completed all quests but my camp wont go to lvl 5
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: cant craft topaz gypsum potions
  • (if a bug) Were you able to recover from the issue: no
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:

please devs help me out here

We’ve also seen multiple reports of this and the development team is aware!

so is there a fix coming or am i just out of luck and can not create that gupsum?

I’m curious as to the solution too, as I just noticed I’m in the exact same boat.

Are we going to be awarded all possible daily rewards/upgrades we would have missed from not even being able to participate in this quest line?

just because you say they are aware doesn’t really put us in a situation where we can just sit here and wait, there are alot of issues we have submitted in beta that you guys said you are aware but never been fix

so what can we expect about this? im like a beggar begging people to put down tier 5 camp for me for over a month now coz you guys are aware of this and yet several patches have gone past and its still not fixed

is there any fix or what to do the potion without a t5 camp?

Hey I had the same issue, apparently I had never completed the first quest for the camps. The camps upgrade once per quest you complete. Not necessarily just doing the tier five quest… and it automatically jumping to five. Make sure you did them all including friends in fashion, monarch’s bluff.

Are you sure you completed all the quests?

Apparently I never did the cutlass keys quest for T3 camp, but I did the T4 and T5 quests. I had a T4 camp available only. Doing yhe cutlass quest “animal instincts” granted me the T5 tent.

Si it seems that you are, INDEED really put in a situation where you can, will and have to wait hu??.. lol

There are tons of us with this problem. We’ve been barking for months. So far all we have only hit brick walls.

The quest “Friends in Fashion” just doesn’t pop and for some “Fading lights” doesn’t. I have visited all the survivalist, even the ones not offering camp quests, several times to try to make it pop…it simply will not…the quest giver tells me to leave.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.