Can’t make a powerful regeneration potion at tier 5 camp

I’m not sure if this is a bug or working as intended. I picked up a project board mission to craft a powerful regen potion however the Mourningdale town alchemy station was to low. I go outside made a level 5 camp but the potion is not even showing up as an option? I have all the ingredients in my inventory.

World Frisladia
Name: Zanarneth
Alchemy lvl is 141

Hello @sllink, :space_invader:

Welcome to the New World Forum!

Sorry for the trouble crafting the Potion. I want to know if you tried to visit a different settlement, i understand you tried using the Tier 5 Camp and do you know if other players have the same issue?

I want to know also the ingredients you have. You can also share screenshots of the Camp and the Arcane Repository when you try to use them. You can also try to find items using the filter option at the top of the left side.

I’ll wait for your reply! :space_invader:

Thanks for the reply. I was able to make the potion at a different settlement, but I had to walk all the way there. :wink: ingredients in image

I made another camp and again the potion doesn’t even show up? ( second image)

Don’t know if anyone else is having the same issue at this time.

Awesome! I’m glad to know you were able to do it!

You can craft the Powerful Regeneration potion only on Aracane Repository, that’s the reason why you don’t see it when you use the Camp Tier 5.

If you need anything else, you can let us know! :space_invader:

Take care! :space_invader:

Thanks, so it is working as intended. That should not be a town project choice when the alchemy station is less than the tier to make it. 💁

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.