Can't add Gems to Old Rings

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Ossterman

  • What server/world did you experience your issue on: Lerna

  • Describe the issue you are experiencing: Can’t add gems to Old Rings

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: Can’t add gems to my armour

  • (if a bug) Were you able to recover from the issue: No

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: Try adding a gem to an Old Ring

3 Likes

Why did you cut the rest of the ring?
Some weapons with chain can’t have differentiating gems for example.
A void chain weapon can only receive void damage gem.

1 Like


That better for you?

I have the same issue with “old earring”

Following.

Hi @Osterman, thanks for pointing this out. Some other adventures have shared this similar but, and with @ExpeditionOne confirming this, I will be sure to include both your details in my existing report. Thanks for the screenshot, it is very helpful while we track things further.

1 Like

Thank you @rayman FYI if it helps, I also created a post regarding my issue, but its essentially the same thing. Empty socketed earring (I bought it off the TP yesterday) and I cant insert a gem whether its on my person or in my bag.

It is, it’s not that. Good of you to report it .

Thank you, Rayman. Appreciate the response :slight_smile:

also have this issue

Patama here from City of Brass just made a gypsum caste of a nice pair of old earrings that will not let me insert a gem into the empty gem socket. Very disappointed!

do you have a plan to fix this?

AGS??? Fix this game @Customer-Service

bump

bump @Arshi @Luxendra @Eivor @Shadow_Fox @Chardis

@Chardis @swarf @KelThuzad @Jochoo @Ulfhundur @Hunden @Fostus @Zweihander @Jormungandrh @skoal can someone take a look on this bug?

Still not fixed…

maaa siii ancora cè tempo, con calma, il tempo che la gente si stufa del tutto di questo gioco

bump

bump

@Chardis @swarf @KelThuzad @Jochoo @Ulfhundur @Hunden @Fostus @Zweihander @Jormungandrh @skoal can someone take a look on this bug?

Blimp