Can't leave a house that I was Viewing

  • What is your character name in New World: B2theAM
  • What server/world did you experience your issue on: Annwyn / EU
  • Describe the issue you are experiencing: Went into a house to view and I can no longer leave
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: I can no longer leave meaning I can no longer play.
  • (if a bug) Were you able to recover from the issue:No
  • What are the steps to reproduce the issue as you experienced: I do not know how to reproduce it and I do not want too. I have read multiple accounts where players get locked into their house and the only fix is logging out? There has to be another way, I will not be able to get back in game for 24 hours if I log out now because the queues are way too long. I have tried Teleporting, Unstuck, Recalling to Inn, teleporting into Amrine dungeon and leaving expedition, pressing “E” for exiting the housing, taking off all my gear and equipping, taking off azoth staff, crawling/walking/crouching moving backwards, even tried crossing my fingers in real life…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.