Can't salvage or repair

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Blimpus
  • What server/world did you experience your issue on: Otuken
  • Describe the issue you are experiencing:when I press s or r to salvage or repair an item in inventory, and then click, does nothing. I also tried alternatively to just click the item then click on either ,but clicking does nothing. This happens randomly.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: couldn’t salvage anything so had to relog. Annoying.
  • (if a bug) Were you able to recover from the issue: yes. Had to log out and back in.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: no idea, happens randomly.

i also had these bug every time when i claimed my Achievements, i restarted the game and it was fine. after the patch yesterday i dont have these bug anymore.

Wasnt after any claiming of achievements, was after I ported back to town but it’s happened maybe 20 times randomly over last few weeks. Even today, after patch.

thats shit bro i hope it will be better one day :smiley:
have a good one.

1 Like

Like the other million bugs, we can all hope lol

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.