Can't sell anything at TP (Insufficient items)

Oh, that is mega annoying, but will test it.

Might test this as well.

Having the same problem. Thought it might be related to the stacking and storage issues acknowledged here but it wouldn’t work even when I tried listing the exact amount of one stack in my held inventory.

IGN: EmpressFox
Server: Yggdrasil

Seems to be related to the “storage is full” issue (showing storage is full when it isn’t)
If I go to a settlement that doesn’t have this then I can sell items from inventory and storage, also I can craft from storage materials (another new bug).

same issue
TheTwoHorn
eden

It seems that the game is trying to take what you are selling from your inventory. If you have some in your inventory and some in storage, but not enough in either separately it will fail.
Put all items in your inventory and sell from there as this worked for me

I can confirm this, happening to me after the patch (and yes, I have them in my inventory):

Too bad AGS jump to release new stuff and keep on piling up to the 260+ known bugs (they released this themselves, lol).

image

  • What is your character name in New World: lanjiaoneverdie
  • What server/world did you experience your issue on: Lagado
  • Describe the issue you are experiencing: Could not sell any items at all in any trading post keeps saying insufficient items. please fix this trash bug. thanks

The way to fix this is you have to find your items under the sell tab you can not search the item and create a sell order you must create all sell orders threw the sell tab only hope this helps (sorry if this has already been answered didn’t want to read all the posts )

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.