Can't sell on trading post - settlement storage is full error

Storage is not full in any town but getting error in multiple towns.

1 Like

Me too

Same

I wonder if people are just running around brimstone and haven’t tried to sell yet, of if it’s only happening to a few. I wanted to put items up for sale before I left for work, but I guess that’s out.

None of my storages are full, I double checked all of them to see if it was a different one keeping me from selling, but it’s not that. They are all well below cap.

Same. new patch, old proplems…

1 Like

Same here all towns…storage full when they aren’t

Appreciate the heads up! This is a current known issue and something the team is looking into. We apologize for the headache it causes!

Just out of curiosity, is this issue maybe related to the fact my home changed in MB and caused one of my storages to go outside my backyard zone thus not allowing me to move it back onto my property? Even though your storage is not full, maybe its an issue with the fact some housing items are incorrectly placed i.e. storages?

you can sell in brimstone sands anything that gives you the full storage error. for me it was chittin plates

@brett2007 can you elaborate on that? I moved everything from my inventory to different storage and still couldn’t trade

@Shadow_Fox this is not a headache, this is a huge issue and acknowledging it is not a sufficient solution.

bro just hit solution for the hell of it. So help me understand the solution here? Maybe your solution you are suggestion is dont play the game? That is what it sounds like, and yes I had not tried to really sell anything yet because I have been running around in brimstone. Now I am trying to sell and somethings I cannot list because it says my storage is full. Why have a PTR again? Moral of this reply is that your solution suggests to stop playing imo.

same issue

I fixed this by picking up all my furniture in Everfall. Stuff was all messed up from the housing model change. I had furniture floating in the air. I picked every piece up and then placed the chests back down and then I was able to sell things. Hope this helps someone.

1 Like

This did it for me too! Thanks

I have the same problem … one of my storage chest is outside the perimeter of my house courtyard…

returning player, just to try out greatsword, really f disappointed with this bug, really liking the changes toward the game, ie able to withdrew from other town,reduction of azoth for travel, but this show how incompetence they are.

i only tried picking / reset storage chest, doesnt work,
i refused to spent time picking up all the furniture, as there is to many and tedious + i had spent time to arranged them at first place why would i need to spent my time to solve their fucking issue.

btw just tp to new town and sell item from there, seems to be ok, but it still super annoying that you cant sell from you base town

Try selling from a town where there’s no house, it worked for me

Not sure if this was supposed to be fixed with the patch, but it has not been fixed.

Still any town where I own a house and have increased storage and using some of that increase it tells me I have a full storage and can’t sell or place buy orders.

I can go to a different town where I do not own a house and where the storage is correctly under the limit and sell and place buy orders there.

Any idea when this will get fixed?

*correction: I own houses in Windsward, Mourningdale, and Brightwood. I can sell from Brightwood, but not the other 2. I even picked up my storage box and trophies and replaced them in Mourningdale and that didn’t help. I didn’t do anything at brightwood, but now I can sell from there.

Any word on this getting resolved it has pretty much halted my farming for selling items as prices are dropping…

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.