Can't turn my character after join Outpost

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Arica
  • What server/world did you experience your issue on: Brittia
  • Describe the issue you are experiencing: While in Yeti Shop menù I entered in the Outpost, can’t turn my character, tried to unstuck, go game menù but nothing.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: can’t play properly
  • (if a bug) Were you able to recover from the issue: yes, close the game worked, of course the game kicked me from the Outpost.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: nop sorry
  • What are the steps to reproduce the issue as you experienced: I think the bug is to enter Outpost while in Yeti shop menù, maybe same thing may happen in any instance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.