Caught in the mountain model, I need help urgently

Server US EAST/valhalla,

ID:LiangQi,

I am stuck in the middle of the mountain model and cannot go out. I have not set a return point, so I cannot use the return point and unstock does not work. I urgently need the official force to let my character return to the town.

I need GM’s help, thank you!

  1. List item

I have been trapped for more than 72 hours, and I need help urgently!

Make this a “support” post, not “General Discussion”

Does reloging not fix the unstuck issue?

Can you move at all?

I was upside down in the terrain in Brimstone and from memory I had to run around until I popped out of the terrain in a random spot.

Otherwise hopefully AGS can help you.

Unfortunately, it didn’t work

The problem has not been solved, please pay attention to me

Have you tried contacting support? Contact Us | Amazon Games

Thank you. I don’t know this contact method. I’m trying to contact them now

1 Like

Hello @771063677,

Welcome to the New World forum, I’m really glad to see you are here at the forums and hope you can enjoy your time here and at the game as well!

I’m really sorry abouyt the issue you’re having with your character being stuck on the mountain model, in this case and due to the nature of your character I can recommend you to reach us via player support using the following link: Contact Us | Amazon Games to create a support ticket and review your case in more depth.

Please make sure to add the DxDiag and Gamelogs through a sharing link from a Cloud Storage like Google Drive to the support report, you can pull it following this steps:

DxDiag report:

  • Go to Windows Start search bar and type dxdiag.
  • Click on dxdiag.exe.
  • When green progress bar goes away, select Save All Information and save the file to their desktop.

GameLogs:

  • Game logs can be found on: \Users\USERNAME\AppData\Local\AGS\New World\CrashDB\reports\

If you need further assistance in any other issue please don’t hesitate in reaching us again!

Cheers!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.