Characters Not Showing on Main Menu

Can anyone please help me out? AGS customer chat has been hopeless.

I haven’t played since the void update but wanted to hop back in. I can see I have 2/2 characters on EU central, but they will not load onto the screen to select and click play. I can’t click settings, I can’t click quit. I can only choose regions and view worlds, which shows nothing.

I’ve done the validation, re installed the anti cheat and reinstalled the game twice as instructed by AGS. Nothing.

Any ideas?

Hi @pete.winfield1!

I hope you are doing well. :smiley:

Is it possible that you send a picture of what the main menu looks like? Like where your characters are. And is there any error message where the characters are supposed to be?

Looking forward to your reply! :slight_smile:

1 Like

There are no errors, the circle just spins endlessly.

Thanks for the quick reply!

I know this may sound weird and I don’t know if you have tried it already but please try this:

Disable ipv6 in network adapter:

  1. From the Start/Windows Menu, select Settings.
  2. Select Network and Internet.
  3. In the Status section, under Change your network settings, select Change adapter options.
  4. When the Network Connections window opens, right-click your network connection.
  5. Select Properties. Scroll to Internet Protocol version 6.
  6. Uncheck the Internet Protocol Version 6 (TCP/IPv6) box.
  7. Select OK to save your changes for the selected network adapter. Try launching the game again.
    A PC restart may be necessary.

Let me know if it helps, I had a similar issue right after the update you mentioned and this helped me out, hopefully it does to you too.

Thanks for the assist, but this didn’t work.

Hey @pete.winfield1

Try to delete these folders:


But be careful: if you delete the folders, all self-made settings will be deleted and replaced by the default settings.

No guarantee but maybe it helps.

Hey, I can’t seem to find this file string. I don’t see AppData. Might it be somewhere else?

Shortcut to this folders is %appdata%

Hello @pete.winfield1

Hope you are doing well!

Can you please let me know if this issue is now fixed? If not I would request you to also try performing the Steam Integrity check, as loss of files or corrupted files, sometimes, may cause these kind of issues.

-Close the game
-Run Integrity check-

-And relaunch the game

@Amara Thank you for your inputs! These steps can be tried but as Amara mentioned please be careful as deleting these folders might change your self made settings to default.

If this doesn’t work, please let me know so that I can escalate it further.

Have a great day! :slight_smile:

Hi, I tried this step with the AGS chat support team. It did not work. My game has also updated today, and still I have no characters.

Hello @pete.winfield1

Thank you for reverting back. I am sorry that the previously mentioned steps did not work out.

However, there are a few more steps that we can try to help resolve this issue.

  1. Flush DNS - At the command prompt (decline restarting your machine until you have entered the final command):
  • Type ipconfig /release and press Enter.
  • Type ipconfig /flushdns and press Enter.
  • Type ipconfig /renew and press Enter. (This will stall for a moment.)
  • Type netsh int ip reset and press Enter. (Don’t restart yet.)
  • Type netsh winsock reset and press Enter.
  • Now restart your machine using Start > Power > Restart once more and test to see if the issue is resolved.
  1. Make sure that your Windows install is fully up to date with no update pending.
  2. Uninstall and Reinstall New World.

Looking forward to your response.



I have completed all of the above and still I have no characters at the menu screen.

Thank you for trying the above mentioned steps @pete.winfield1

To further escalate this I would request you to please contact our live mediums here Contact Us | Amazon Games so that we can create a ticket to the Dev team & help you with a resolution.

Be sure to have your game logs ready in case they ask for them:

Provide the latest 3 logs from: Users\AppData\Local\AGS\New World\LogBackups

DxDiag report

  1. Go to Windows Start search bar and type dxdiag.
  2. Click on dxdiag.exe.
  3. When green progress bar goes away, select Save All Information and save the file to their desktop.

I hope this helps.

Thank you & have a great day!

I started with the live assistance before I came here and they sent me to the forums when they couldn’t fix it… Do I just not get to play the game I paid for?

Hello @pete.winfield1

I understand your concern here. The only way to proceed with this issue is to create a ticket to the Dev team and since we cannot create one over the forums, I humbly request you to please reach out to live chat once again and give them the link to this post so that they know the troubleshooting steps which you have already tried. Request them to assist you in creating a ticket to the Devs team directly and in helping you with a faster resolution

I am sorry for all the troubles you are facing and I understand how frustrating this must be & I wouldn’t have requested you to do this if it wasn’t absolutely necessary.

Thank you for understanding.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.