Chat lagging behind significantly

  • What is your character name in New World: Reset
  • What server/world did you experience your issue on: Yggdrasil
  • Describe the issue you are experiencing: Whenever you mute some channels in text chat (In my example, I usually mute global, recruitment and area). It seems to play new incoming/outgoing chats into some sort of a buffer that you don’t see until enough chats have come through to scroll you through it. If you unmute all the channels, all missing messages show up immediately. This seems to get worse and worse with the more when you have more messages that are muted. I got to the point where I would type a message and I wouldn’t see it post in my chat for almost 5 minutes. Other users report that they see the message immediately when I type it, it’s just my chat box thats being slow/lagged.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Makes text chat annoying to work with
  • (if a bug) Were you able to recover from the issue: Nothing to recover really
  • What are the steps to reproduce the issue as you experienced: Mute several channels, allow a bit of time to pass, then start typing in chat, or have someone send you a test message. It will take quite a while to actually show up in your chat box
9 Likes

As an update to this, it only actually seems to happen when I mute global chat, as far as I can tell

3 Likes

I can confirm. I unmute Global and then mute again. That’s all it takes.

2 Likes

I am also seeing this. Fixes listed above work but this is annoying to do every time it happens.

1 Like

@luke1lea Temp Fix: Change from Feed on the left side when having chat open to the chat you wish to display. Feed lags the incoming messages.

Linking another thread … same topic.

Same here. Up!

Same, this is still happening.

Just adding a summary of additional posts on this matter after this one was created to show how widepsread the problem is.

So is the issue solely with the feed? I feel like I saw lag even in the specific channels but I cannot remember. I will test things again next time it happens.

The issue is if you set the chat filters to (mute) or (alert) for some channels in the chat options and then select the feed channel, the game is buffering all of those messages which are muted or marked for alert. So, until they are viewed (by manually clicking on each channel or removing the mute/alert) it causes increasing chat delay.

Symptoms look like they have a loop in the code where it repeatedly iterates through every buffered message when a new messages is handled. Once you either clear that buffer (by manually looking at the muted channel or restting the mute filter, all delay stops until it backs up again with more.

same here 3 min delay in chat

yes

bump

PSA: If you set global to mute, put it back to feed. It should fix the chat lag.

Can staff fix this? Muting and unmuting does not work for me.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.