Chat restriction to 72 hours

  • What is your character name in New World: Hopium
  • What server/world did you experience your issue on: Olympus
  • Describe the issue you are experiencing: cannot chat in global or any of the other chatboxes except whisper and company chat, even though i have over 300 hours in game
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: cannot chat in global etc.
  • (if a bug) Were you able to recover from the issue:
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced:

I have no bans or any red flags on this account, but i am chat restricted?

Have you tried relogging? [Downtime] New World Update 1.0.5 - #2 by Luxendra

i have this issue too. and i have relogged i have closed teh game down. closed steam down. nothing works.

no i relogged multiple times and still cannot chat in Global or Recruitment. I am able to chat in all other chat channels. dunno if that helps in accessing the issue or not :confused:

please please please can you forward to the dev team the musket dodge not rolling the full roll distance compared to every other weapon, its literally breaking mobility with this weapon.

Is this maybe due to family sharing?

1 Like

I had this same issue starting last night. Can’t chat in Global (didn’t check the others) but Faction chat did work.
I’ve never used Family Sharing.

And you had the “Global Restrictions 72 hours” pop up?

I honestly don’t remember seeing that at any time. But I also still have the achievement bug where I get pop-ups when I load in for at least some of my achievements so I’m used to clicking things off the screen right away. I’ll pay more attention next time I log in and give an update.

Mine is, bought a new copy of the game.

I’ve same issue, i can’t talk on any public chat, recruitment, etc but only able to talk on group/alliance chat and i don’t have any pop-up of 72h restrictions ( have already 550h+ playtime ) on Lyonesse EU Central, my name is Luffy75 .

no my family sharing settings are off on Steam. i also cannot do player to player trade for up to 10 days along with the 72 hours global chat restriction

1 Like

can’t global chat, trade or send gold at all, relogged multiple times. This started after i bought a copy for my previously family shared account.

I’ve had this issue yesterday, unable to chat in global chat, but every other chat worked. No message on screen with the 72h restrictions, and today the chat works.

Understood. I’ve brought it up for investigation since it looks like there may be a few variants of this issue.

1 Like

I’m also getting this for a copy I just bought yesterday. Am I not allowed to chat until my account is 72 hours old? I’m level 13…

yes relog but how to relog in game ? where is option log out ? where is option to log in ?

i log out from steam.
i close game 12 times to type on global and if i am lucky than i can type …
it is so annoying.

I have the same problem, I’m lvl 43, started playing November 2 which is older than 72 hours but can’t chat in global channels.

I have this as well and had family sharing but purchased another copy of the game. Still unable to chat due to the 72 hour restriction.

Server - Pahruli
Name - Rend Ericson

Having the same issue. Can talk in company chat but nothing else. Don’t remember seeing anything about a 72 hour restriction. Relogged and even reset chat settings, nothing as worked so far.