Company name bugged out

  • Describe the issue you are experiencing: My friend made a company to reserve the company name, he went to transfer me the company name but deleting his character because of the massive queue. I was ready and waiting to make the company myself, with that company name. The company name did not become available when my friend deleted his character, the instant he deleted it and for 20mins after I tried to create the company but it did not become available. He than made another character and tried to make the company again with the same name but he cannot either. The company name is now bugged out and no one can make it with that name, its like its locked to the deleted character.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: We cannot make the company with the name we want.
  • What are the steps to reproduce the issue as you experienced: We have tested this with a random bunch of numbers that no one could possibly be trying to make a company name with and once you delete a character with that company name, without leaving the company, that company still must exist but with no one in it.

Hey, I had a very similar issue, however, I didn’t delete the character, I just changed the name of the company, and tried to change it back instantly and it would say”company name is in use” So now i’m confused on what to do here as well.

Did you figure it out? Or did it resolve itself yet? I am having the same issue…

name is goneeee sadly.

I’m having the same issue and we tried creating the company immediately.

We are experiencing the same issue. :upside_down_face:

I also have the same issue

Somewhere throughout the night, our company name became available once again after renaming the EU company. Make sure to check if yours is available now!

We have this same exact issue while trying to go from EU to NA.

It’s been about 17 hours now in all and still no luck.

I submitted a ticket as well but got that same generic response about them being recycled immediately, which is obviously inaccurate.

Anyone else had luck getting theirs back? How long did it take you?

Yea I am having the same issue, saved a company name on US East, Deleted that Character to move to US West to avoid queue. Character Name was instantly available, but the Company name is still not

The problem is now the company still exists but with 0 members =( I’ve asked support to delete my company with 0 members but they wont lol

Same issue here, disbanded the company as we changed factions, and tried to create a new company with that same name almost immediately. which should be instantly recycled but it’s obviously bugged. It would be highly unlikely someone secured the exact name of our company only 1 minute after disbanding it.

Same goes for me, we wanted to change a uppercase letter to lower case and it says the name is in use.

Can we make it so it’s instantly useable again after deleting the company name?

UPDATE: I’ve queued for and hour to talk to an admin in the live chat.

He basically said that the company names could be released somewhere between the very moment you disband/change the faction name, to up to 24 hours after the fact.

There is seemingly no way to find out whether it has been taken or you’re still waiting, except to escalate the issue to another support team which apparently will take 48 hours.

Below is my chat with the online chat to save you the time if you’re interested.

Live Chat Logs

Me : Hi I have a problem with the new world companies
[Live Admin] : Okay [Redacted], I can help you with that, please elaborate what the issue is.
Me : My group of friends and I have are playing on the [Redacted] server [Redacted], we’ve made a Covenant company early to secure the name: [Redacted].
Me : Thought since then, we’ve decided to switch to Mauraders and we disbanded the company last night.
Me : Upon trying to create the marauder company with the same name: [Redacted], we believe it’s bugged because it says the name is taken
Me : I’ve looked on the forums and many people have had the same issue of this kind
Me : Even around 16 hours after the fact, it says the name is still unavailable
[Live Admin] : [Redacted], usually names are released right at the moment of deletion and the maximum amount of time it takes for a name to be released is 24 hours.
[Live Admin] : Even after 24 hours, if the names are not available to you, that means someone else has taken the name as you released it by disbanding the company.
Me : Okay, so how can I know exactly when the name is going to be released, so I can once again secure our name
Me : Because it’s very important to us, we’ve called our group this name for several years now
Me : Thanks
[Live Admin] : That would be 24hrs from the time you have disbanded the company
Me : Is there any way that we could secure the name now?
[Live Admin] : No, I am afraid not.
Me : It just seems a little bit funny that it could get released any time and anyone could secure in that time, surely there’s a way we could get it done
[Live Admin] : [Redacted], we cannot manually assign a company name to you.
[Live Admin] : As I said, it should be released instantly but sometimes it might take a maximum of 24 hours to be released.
Me : I agree manually assigning a name to me would be farfetched, but it would really help us out if the name could just be manually released, is there any way to do that?
[Live Admin] : No but if I escalate this, our teams will be able to let us know if the name is available to claim but that takes about 48 hours to be done as we are getting a huge number of requests, reports and appeal.
[Live Admin] : which is longer than the wait time for the name to be released
Me : Well I think it would be smart to at least try, given that it’s impossible to check if anyone has taken it in the past 8 hours while we were sleeping.
Me : Can we do that?
[Live Admin] : Yes, please provide me the following details
[Live Admin] : - In Game Name
[Live Admin] : - Server Name
[Live Admin] : - Region ( US / EU / Australia )
Me : In Game Name: [Redacted]
Me : Server Name: [Redacted]
Me : Region: [Redacted]
[Live Admin] : Thanks for the confirmation, please allow me a moment while I escalate this
Me : Thank you very much
[Live Admin] : I have escalated this issue and I will reach out to you over email as soon as we get an update.
Me : Thank you so much for the help [Redacted]
Me : I hope you have a great rest of your day
[Live Admin] : Apart from this, is there something else I can assist you with ?
Me : No that’s all for now

It has been more than 72 hours since the name hasn’t been recycled.

I’ll make sure to bother live chat about it again.

1 Like

UPDATE: So they must have deleted the guilds with 0 members and our guild name became available, though someone else took it with 4 members in it. Who knows when this happened, very frustrating to say the least.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.