Company Name Burned/Unusable

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: SovereignCo
  • What server/world did you experience your issue on: Valhalla
  • Describe the issue you are experiencing: Company Name saved on a EU server burned after renaming to use on home server
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Weeks of planning coming apart at the seams with this & queue times
  • (if a bug) Were you able to recover from the issue: I guess?
  • What are the steps to reproduce the issue as you experienced: Created a company with random letters, renamed, could not change name back. Tried this on both EU and US East
1 Like

Same issue. Would be nice to be notified when this issue is fixed so we can get the name we originally had.

Having the exact same issue as well

Did you get this resolved? If so how?

It’s been resolved and I have no idea why. I just kept trying to change the new company’s name to the one I tried reserving, every day.

So you ended up getting it in the end? How many days did it take?

It took about 1 - 2 days before it was unlocked and we were able to secure it on the new server.

Great, thanks for the quick reply!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.