Complete the Ritual bugged

Dumont Destro
US East
Valhalla

Can’t complete the ritual. I light the columns and defeat the boss but every time I try to use the stone it just cripples me for s second and then the boss respawns?

Yet another Main quest delay!

Glad I’m not the only one this has happen to. I just experienced this issue! I tried even logging off right around the area but it did not fix it.

  • Acidragon
  • As per the OP said. I light all the pillars, kill the boss and it does the whole animation but once complete does not complete that part of the quest.
  • 11/8/22 around 9:30pm (arizona time)
  • Isabella
  • The Ritual quest line (where you give your soul up)

Ok so I found a work around for this bug. Just keep spamming the animation, it took three tries and on the 3rd attempt it worked.

1 Like

I’ll give it s shot

Welcome to the New World forum community and thanks for letting us know that you have this bug.

Thanks for reporting the bug as well, Dumont. Please let us know if that workaround works!

I have done this 10 times. kept spamming the animation, I dont die but the boss spawns, light the pillars, kill the boss, quest reverts back to Complete the Ritual. Rinse and repeat. Over and Over and Over. Logged out and back in Same thing happens. Stuck on main story line. Gave up. I previously helped my brother with this quest but I did not have the quest at the time. Maybe that has screwed it up?

  • What is your character name in New World: K’yra002
  • What server/world did you experience your issue on: US EAST - Lillith
  • Describe the issue you are experiencing: I kill and loot the boss and the quest reverts to the beginning
  • Is this a bug? YES
  • (if a bug) How did the issue affect your gameplay: I can’t continue the main story line
  • (if a bug) Were you able to recover from the issue: No, I have tried multiple times to no avail
  • What are the steps to reproduce the issue as you experienced: Go into the ritual quest area… and see for yourself…
  • When did this happen? November 22, 2022

Wish I could help but I’m not even sure how I got it to work. Just kept trying it and it finally took. Really frustrating. No big deal if it’s a side quest but main sucks. Unfortunately it’s happened too me a few other times on main quests also. Somehow I usually get them ot work.

Thanks Dumont. I took your advice and tried again. This time on the third time through it actually advanced. Yeah! Thanks again.

1 Like