Connection failed. Login Service isn't available at this moment


So, another day, another error during queue, awesome. While it says “reconnecting”, it actually isn’t doing anything for about 30 min, then in gives me second error. Tried to requeue 2 times, both times happening after around 20 min in queue. Anyone with simular issue or even possible workaround?

1 Like

Similar issue. No workaround yet

Sadly, no solution for now. I’ve been trying to reach the server I play on 5 times today, and each time I received this “login service isn’t available” error after an hour in the queue. Looks like I’m the chosen one, since the number of people in the queue was only increasing.

Have this problem to. After re-entering the game, the characters are no longer displayed, but 4 slots for them

Hello all,

Im sorry for the issue you currently have. Please check the following in order to try to fix the situation: Troubleshooting Lag and Connectivity Issues - Support | Amazon Games.

Also you can check: For most connection related (Lag, Latency) issues, begin with the following basic troubleshooting steps:

  1. Restart your PC and disconnect the power to your Modem and/or Router for 60 seconds.
  2. Reconnect the power and wait for the internet connection to be restored before powering your PC back on and attempting to access the game.
  3. Try switching from a Wireless connection to a Wired one (if possible).

If that doesn’t help, we’ll need to completely reset and refresh the connection your computer has to the internet:

  1. From the Start menu, begin typing ‘cmd’.
  2. In the results that populate, right-click the Command Prompt result and select Run as administrator.
  3. Type ipconfig /flushdns and press Enter. Wait a few seconds and when the command prompt appears, proceed to the next step.
  4. Type ipconfig /registerdns and press Enter.
  5. Type ipconfig /release and press Enter.
  6. Type ipconfig /renew and press Enter.
  7. Type netsh winsock reset and press Enter.
  8. Restart your computer.

Connection Failed: Unable to establish connection with the server
Resolving this issue will require allowing or adding ‘newworld.exe’ to your Firewall.
If you do not have 3rd party Firewall software installed, this can be added via Windows Defender using the following steps:

  1. Select the Start/Windows button > Settings > Update & Security > Windows Security and then Firewall & network protection.
  2. Select Allow an app through firewall.
  3. Look for and select ‘newworld.exe’ in the list of installed apps.
  4. Select OK.

Once added, try relaunching the Game again and confirm you are able to play without error.

From Welcome to New World!

Thank you for your patience and understanding!

Why do you give same answers every time that does not help anyone at all? Restart your computer? Rly? Why? I’m playing online games with no single dc or lag. Restart for what reason?To wait another 4 hours in queue untill next error? 2 days since this post Launch Day Update and there is zero updates! Relocate character? And what about 50+ guildmembers i came here to play with? 1 day problems - it’s ok for release. 2 day prodlems - ok, i can understand. 3 day is almost over and nothing cahanges? Got even worse!

1 Like

Wow, just wow.

This is the worst copy paste IT advice ever. The problem for the majority of players is on your end, not on theirs.

Next day, PC rebooted, DNS flushed, still same error, can’t even pass 300 queue (which is 700 now) because of that, great gaming experience.

Thanks for suggesting help for random error nobody here is experiencing, i guess…

2 Likes

3rd day have the same problem. pc rebooted ~15 times, router 5 more, but the interesting thing, i have -ping 100000000 to google.com, while im queuing this game, and there is no packet losses at all, at the same time i watching stream/serial, and using voice with friends. so is it really PLAYERS problem, or you just copypasted this from microsoft forum?

Spent whole day trying to find a workaround, no success. I have tried to press “ok”, press “x”, wait for a queue to appear after, press “play” - nothing works, it just stops working after that error. I keep wondering, how is that possible to create all this error codes like this one, put them in the game, but still know nothing about what can possible cause said errors to appear in client? Was queue system even tested before release?

The solution of the problem from the support service can not help even in theory, because if you just restart the game everything is fine and you can safely get in line.
There are constant queues of 4000 people on my server, but because of this error, I can only enter the game at night when the queues drop to ~ 500 people. If there are 1000 people in the queue in front of me, then sooner or later this error will appear, and if all other errors can be easily ignored by simply clicking OK, then when you click OK in this error, the queue just ends for me, and I can only restart the game.
This error alone, which does not allow me to play even if I was ready to wait more than ten hours in line, ruin the whole impression of the game. And the devs can not only fix this problem but also can not give current advice on how to avoid it

Well, it seems that i have found a solution, at least i am no longer receiving this error after changing my DNS servers to Google Public DNS. If you still have this issue - try it, google has instructions.

I keep getting this error as well making it impossible to login and play. I don’t mind the queue but with those errors its literally impossible to play. I don’t have any connectivity issues and if I do login early morning (no queues) I wont dc, I’ve played countless online games before with and without queues and never had an issue. My connection is stable, I’ve verified game files etc. Tried more stuff but nothing works. Hope this gets fixed.

1 Like

Sad but this won’t work to Russia because our gov.under.imagination forced internet providers to block any connections to Google PubDNS :frowning:

I had the same problem until yesterday, but it’s gone after last MT. But anyway even after no disconnection due a que - you can’t play if you waited more than 2.5-3h. After u hit 1 place in a que you got a couple of loading screens and just pushed to a game starting screen with a news, just before a character selection screen.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.