Crafted falmea's wrath but cant complete it

****** Please make sure you fill out the following information before submitting a report ******

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: pineapple magus

  • What server/world did you experience your issue on: frislandia

  • Describe the issue you are experiencing: i have crafted the flame staff noted in the quest log and it did not count and as it requires drops only found when doing the quest it would be a huge time sink to restart the chain

  • Is this a bug? (If this is an exploit, please follow the steps here: [Dev Blog] How to Report Exploits - Updated)

  • (if a bug) How did the issue affect your gameplay: cant complete quest

  • (if a bug) Were you able to recover from the issue: no

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

  • What are the steps to reproduce the issue as you experienced: try completing the quest?

  • When did this happen? (Date and Relative time; please include your timezone)

Welcome to the New World forum community. I’ll get this over to the development team for you.

I am also having this issue. Crafted it and equipped it still cant hand in the quest -
Edwin Grim AP servers

I am having this same issue. Crafted Falmea’s Wrath but did not recieve a checkmark for that step of the quest and thus I can not turn this quest in. I am having the same issue with “Tracking the Huntress” quest after making The Huntress.

i dont know what gear level its supposed to craft at but it is 500 GS and i think its supposed to be something else

Thanks y’all for letting us know! It appears that there’s a bug with this quest and the team is taking a look into it.

I have the same problem with Falmea’s Wrath and The Huntress.
I also tried resetting the Quest, but same result.

same as the OP, i’ve dropped the weapon, picked up, logged out/back in, equipped, unequipped, even stupidly…reset the quest, forcing me to redo the whole thing again despite having the staff in posession, if any CM wants to check, my IGN is Mortaal on caer midi

Same problem here, Ryetwar on Niflheim has the staff equipped and still can’t complete the quest, looking forward to how the team find a resolution

Have the same bug. Teyrina on Nysa. Crafted Falmea’s Wrath after gathering the materials, and quest did not update.

They’re looking into this issue!

still unresolved (it did just happened to me as well). Replying to keep this post open.

Same issue here! It’s been 11d since they said they were looking into it and still not solved?

This quest is getting fixed with the update happening tonight: New World Update 1.7.1 - News | New World - Open World MMO PC Game

Still have that same bug as OP

Is it the arcane station bug? Did you try entering a couple of times?

Yes, the arcane station doesn’t tick. I tried to enter multiple times and i also reset the quest but still didn’t manage to get it to work.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.