Crashing during launch/not launching

Could not install EAC, got copy error fixed that, started to get CreateError.

Made EAC a trustedinstaller, now it just won’t start up at all.

Trying to reinstall for a 3rd time on another drive, see if I can get any luck this time.

Any suggestions on what I can do to get this resolved. I would like to play this game.

Hello @mjackson2301 ,

Im sorry for the issue you have. You might need to reinstall the whole game or please try the following. Close and relaunch the Steam client. Then go to Steam Support :: Verify Integrity of Game Files in order to Verify Integrity of Game Files. Look for the game directory, and then select the subfolder “EasyAntiCheat.” Click EasyAntiCheat_Setup.exe to run the installer, and relaunch the game when complete.

Thank you so much for your patience during this launch time.

I have done that. I am working with chat now.

Me [1:15:28 PM] : Hello, I am having issue getting game to launch
Me [1:15:49 PM] : I have reinstalled 3 times now
Me [1:16:10 PM] : game just lingers for min and closes or I get the following error
Me [1:16:11 PM] : GameID: 271 (32bit)
Me [1:16:11 PM] : Windows Version: 10.0 (Build 19043)
Me [1:16:11 PM] : Error Code: 30005
Me [1:16:11 PM] : Process Exit Code: 0h
Me [1:16:11 PM] : UUID: e5991672-59cf-f5dc-78cd-16f706f1a18c
Me [1:16:11 PM] : Process list:
Me [1:16:11 PM] : apcsystray.exe
Me [1:16:11 PM] : applemobiledeviceservice.exe
Me [1:16:11 PM] : applicationframehost.exe
Me [1:16:11 PM] : atkexcomsvc.exe
Me [1:16:11 PM] : audiodg.exe
Me [1:16:11 PM] : bdredline.exe
Me [1:16:11 PM] : btwrsupportservice.exe
Me [1:16:11 PM] : conhost.exe
Me [1:16:11 PM] : csrss.exe
Me [1:16:11 PM] : ctfmon.exe
Me [1:16:11 PM] : dashost.exe
Me [1:16:11 PM] : dataserv.exe
Me [1:16:11 PM] : discoverysrv.exe
Me [1:16:11 PM] : dllhost.exe
Me [1:16:11 PM] : dwm.exe
Me [1:16:11 PM] : explorer.exe
Me [1:16:11 PM] : fontdrvhost.exe
Me [1:16:11 PM] : gamecrashuploader.exe
Me [1:16:11 PM] : gamingservices.exe
Me [1:16:11 PM] : gamingservicesnet.exe
Me [1:16:11 PM] : googlecrashhandler.exe
Me [1:16:11 PM] : googlecrashhandler64.exe
Me [1:16:11 PM] : jusched.exe
Me [1:16:11 PM] : lcore.exe
Me [1:16:11 PM] : lockapp.exe
Me [1:16:11 PM] : logiregistryservice.exe
Me [1:16:11 PM] : lsass.exe
Me [1:16:11 PM] : mainserv.exe
Me [1:16:11 PM] : memory compression
Me [1:16:11 PM] : microsoftedgeupdate.exe
Me [1:16:11 PM] : msiafterburner.exe
Me [1:16:11 PM] : msmpeng.exe
Me [1:16:11 PM] : newworld.exe
Me [1:16:11 PM] : newworldlauncher.exe
Me [1:16:11 PM] : nissrv.exe
Me [1:16:11 PM] : nvcontainer.exe
Me [1:16:11 PM] : nvdisplay.container.exe
Me [1:16:11 PM] : nvidia web helper.exe
Me [1:16:11 PM] : officeclicktorun.exe
Me [1:16:11 PM] : productagentservice.exe
Me [1:16:11 PM] : registry
Me [1:16:11 PM] : runtimebroker.exe
Me [1:16:11 PM] : searchapp.exe
Me [1:16:11 PM] : searchindexer.exe
Me [1:16:11 PM] : securityhealthservice.exe
Me [1:16:11 PM] : securityhealthsystray.exe
Me [1:16:11 PM] : services.exe
Me [1:16:11 PM] : settingsynchost.exe
Me [1:16:11 PM] : sgrmbroker.exe
Me [1:16:11 PM] : shellexperiencehost.exe
Me [1:16:11 PM] : sihost.exe
Me [1:16:11 PM] : smartscreen.exe
Me [1:16:11 PM] : smss.exe
Me [1:16:11 PM] : spoolsv.exe
Me [1:16:11 PM] : startmenuexperiencehost.exe
Me [1:16:11 PM] : steam.exe
Me [1:16:11 PM] : steamservice.exe
Me [1:16:11 PM] : steamwebhelper.exe
Me [1:16:11 PM] : svchost.exe
Me [1:16:11 PM] : taskhostw.exe
Me [1:16:11 PM] : teamviewer_service.exe
Me [1:16:11 PM] : textinputhost.exe
Me [1:16:11 PM] : wininit.exe
Me [1:16:11 PM] : winlogon.exe
Me [1:16:11 PM] : winstore.app.exe
Me [1:16:11 PM] : wmiprvse.exe
Me [1:16:11 PM] : wudfhost.exe
Me [1:16:11 PM] : yourphone.exe
Me [1:17:22 PM] : Running windows 10 i54690k gtx 1060 6g 16 ram

David [1:17:55 PM] : I’m sorry to hear that, The error you get is the first part before process list right?

Me [1:18:15 PM] : error 30005
Me [1:18:42 PM] : I have removed and reinstalled EAC multiple times

David [1:18:51 PM] : This error has to do with a faulty EAC installation

Me [1:18:53 PM] : updated all my drivers
Me [1:19:09 PM] : EAC works for all my other EAC games just not this one game

David [1:19:22 PM] : Got it, how did you reinstall EAC?

Me [1:19:55 PM] : I deleted EAC from the EAC folder.
Me [1:20:19 PM] : Then I used the EAC setup in new world folder
Me [1:20:29 PM] : I used the removed tool and install tool

David [1:21:05 PM] : I see, that usually does the trick for this error.

Me [1:21:12 PM] : I then located EAC.sys file in the game delete that and did reinstall and same issue

David [1:21:26 PM] : Can you try to verify file integrity on Steam?

Me [1:21:31 PM] : I did that 3 times
Me [1:21:46 PM] : no change
Me [1:22:03 PM] : between each game install I did that.
Me [1:22:19 PM] : I even installed on a different hard drive and no change.
Me [1:23:19 PM] : Out of desperation I even did all the run as admin tricks and made sure EAC has trusted installer rights
Me [1:24:26 PM] : Disable all overlays and tried with fresh window startup with just windows programs running

David [1:26:40 PM] : I see, that’s really strange, do you by any chance have RGB lighting for your PC?

Me [1:26:49 PM] : no RGB lights

David [1:28:15 PM] : And both new world and EAC are white listed on your antivirus and firewall?

Me [1:28:20 PM] : yep
Me [1:28:32 PM] : the folder and the exe files to be sage
Me [1:28:34 PM] : *safe
Me [1:28:53 PM] : EAC works fine on my other two EAC games on the pc just the EAC for New world
Me [1:28:57 PM] : is not working
Me [1:29:31 PM] : It will launch and then I get the error or it just stop in steam but it will show in task manager until I close it and then I can run other games no prob
Me [1:30:30 PM] : I am running out of time before I refund on steam I am at 50 some odd mins but the game never launched pass the 30005 error screen

David [1:34:06 PM] : I understand, you have tried almost everything and I find it strange that you can use it on the other two games, we can file a ticket but it can take up to 3 days to be resolved
David [1:34:45 PM] : The only other step I can think of is enabling the service on windows

Me [1:35:06 PM] : Are you talking about enable EAC to auto? I did that too

David [1:35:33 PM] : So you did everything possible basically

Me [1:35:53 PM] : Please fill a ticket I will wait for result and see if they can figure it out and if not refund game then

David [1:37:08 PM] : Will do, do you have any logs you can send me?

Me [1:37:22 PM] : do you want crash logs?
Me [1:37:59 PM] : or APP data

David [1:38:13 PM] : crash logs

What did you find? I have not gotten the game to launch yet today… reinstalled EAC and now I don’t even get an error screen. Says the game is running in background processes, but otherwise will not launch!

dont get offended by this, but if you have any cheats on your comp for other games I would suggest removing them first since as Im reading this it looks like that but I can be mistaken here…

nope… I have a few games installed. warface, ESO and Minion to deal with addons

So I did get it to work…

I have 2 monitors one 4k and one 1920x1080. I had to disable 4k monitor.

After that I was able to launch game but I received the following error

‘Unexpected steam_appid.txt file found’

So I followed the following steps:

How to Fix New World ‘Unexpected steam_appid.txt file found’ Error

If you get the New World ‘Unexpected steam_appid.txt file found’ error, it means the named text file has been created and that’s the reason you cannot open the game. Steam creates this file when certain games have the admin privilege, it doesn’t happen with all games and in this case, the NewWorldLauncher.exe has admin rights, which is leading to the error. So, to fix the error, here are the steps you need to follow.

1. From the Steam Library, right-click on New World > Manage > Click on Browse Local Files
2. You should not be able to locate the steam_appid.txt in the window that opened
3. Delate the steam_appid.txt
4. Right-click on NewWorldLauncher.exe and choose Properties
5. Go to the Compatibility tab and uncheck Run this program as an administrator.

delete steam_appid.txt file

The reason you are seeing this error is because of the game launcher running in admin mode. Once you delete the file and revoke the admin privilege, the file will not be created and you can run the game without the New World Steam_appid error.

Finally, after all that I was able to load into game with no issue. Just can’t have my 4k monitor when I play or it won’t launch.

1 Like

whats is the native resolution on your 4k monitor and whats is your current GPU since you sir have tickled my interests ?

yeah I do not have that file…

My 4k resolution 3840 x 2160
Gtx 1060 6gb. Nothing fancy. I don’t know why the monitor trick worked for me.

sir that card cant handle graps like that try lowering graphics 1080p for starters, you need a atleast 2080 or bigger card for 4k graphics

Still won’t launch the game… I had an amazon rep tell me to delete my Roaming\AGS folder… rebooted… still won’t launch… guess I will contact them again

MaryannCross are there any common programs that might cause the anti cheat to mess up and not launch the game without an error? I have an xbox game bar… probably don’t need that. minion, steam etc in the background

My Girlfriend have te same problem and more freezing probs but for ur error take this it works fine
Steamappid.txt error fix

This is not my issue… no errors and that option is not checked for me. Basically my launcher never loads… just sits there with the game running in the back ground under background processes. The launcher never appears on my screen… I have to use task manager to shut that down just to try again. Nothing I have done helps so far.

My PC was not quite good enough to run it so I am asking for a refund…

Sorry to hear that

And Steam does not want to issue a refund because they say I “Played” 3 hours… The game logs you as playing even if it won’t launch! I have asked a second time for a refund and explained this! I highly suggest that everyone be sure their computer can run it by visiting the link so you don’t go through what I went through.

I don’t game in 4k not why I have the 4k monitor. 1080 is perfectly fine for my gaming hobby. So thanks for input but game runs fine now for my needs.

i have a similar Easy Anticheat issue… oddly, the game has launched fine twice but all the other times i get an EAC error (14, 15, 25, & 10011)… running on a laptop without an external monitor, on regular 1920 x 1080 so the resolution shouldn’t be an issue. i’ve repaired/removed/reinstalled EAC, verified the steam files, whitelisted EAC & steam in antivirus & firewall, closed all other programs, basically everything i can think of or has been mentioned online… submitted a ticket to EAC two days ago but haven’t heard back yet.

fwiw, it launches fine on my desktop. /shrug

any more ideas welcome!