Crashing on Startup with no error

I’ve been trying all day to fix this with every fix I’ve been able to find and nothings worked.

Earlier when I first downloaded it, the game would close on loading screens without any errors. After a couple tries I was able to make my character and load in. But after playing for about 15 minutes or so the game closed itself again with no error. When I was playing my graphics were all set to low and I made sure to cap my FPS, it was running smoothly with no problems and nothing specifically happened when it closed itself.

After that it consistently kept closing itself on startup. It would open the first New World loading screen, load a couple seconds, then close back to desktop again with no error.

My boyfriend played on this exact PC with zero issues all through the beta, and it worked perfectly fine for the 15 minutes I was able to play, so my system shouldn’t have any problems running the game,

I’ve tried every solution I can find and nothing has worked, I have the most updated NVIDIA update, most recent Windows 10 update, I tried allocating virtual memory, verifying files, deleting specific files in %appdate%, completely reinstalling the game, and probably some more things as well, this has been an entire day of struggles.

The PC specs are

|Processor| Intel(R) Core™ i5-10300H CPU @ 2.50GHz 2.50 GHz
|Installed RAM| 8.00 GB
|GPU| NVIDIA GeForce GTX 1650
|OS| Windows 10

I understand 8GB Ram is rather low but it is listed as the minimum on steam and this PC has previously been able to run the game just fine, I also know of many people who are running it with 8GB perfectly fine.

1 Like

I found this in installscript.vdf:

"easyanticheat"
		{
			"HasRunKey"		"HKEY_LOCAL_MACHINE\\Software\\Valve\\Steam\\Apps\\newworld_EAC"
			"process 1"		"%INSTALLDIR%\\EasyAntiCheat\\EasyAntiCheat_Setup.exe"
			"command 1"		"install 271 -console"
		}

This does not exist on my computer, instead, it is in WOW6432Node. My friend has a key easyanticheat.

I don’t think I am having an easy anticheat problem, but I did try to repair it just in case.

I’m only able to get to this screen then it just closes to my desktop

My game never crashes on its own but if I click it will want me to close the program or wait. Same screen though, initial splash screen and … nothing.

Hi @Dym

Im really sorry for the issues you are getting now. Please try the following: Basic Troubleshooting Tips

  • If you run into issues launching the game and your system meets the minimum requirements, be sure to verify the integrity of the game client files using the steps here: Steam File Integrity Check.
  • Confirm that you are using the most recent GPU drivers for your Graphics Card (AMD ) (NVIDIA ).
  • Confirm that you have the most recent updates installed for Windows 10.
  • Check that you have the most recent BIOS updates installed (important for newer AMD Chipsets and Motherboards).
  • Try a clean boot of Windows: How to perform a clean boot in Windows . (This will disable all non-essential programs from starting and test if there’s any background programs causing a conflict with the game.)

Pelase check the following for more information: Welcome to New World!

Its much appreciated. Thank you in advance.

My mouse will turn into the little blue loading circle on the screen, like it would do as if I clicked it it would say not responding. But it doesn’t do anything if I click, it just eventually closes itself.

Same exact issue.

I’ve done all of these before posting. Like I have said, this has been… an experience with this launch. I have been patient but it is growing thin now. I have 1 hour of actual gameplay in, the rest have been waiting in queue and now the game doesn’t even launch. I don’t know how much more I will tolerate. I have returned games for much less and never looked back. Hopefully, there is a fix coming down the pipe and hot fixes should be a thing by now…

I had repeated crashing on day 1, I couldn’t get past the screen show above except for one time getting to the ToS screen, but crashing before I could accept. Culprit turned out to be a slightly unstable CPU overclock. Backed it down VERY slightly and haven’t had a problem since.

I’ve done all of those, some of them multiple times. I appreciate the welcome but doesn’t mean much if I cannot even play the game. I’ve tried every solution I could find on the forums and online in general, still have the issue.

How would I change this? I’m not particularly the best tech guru.

Based on your post, I’d be pretty comfortable saying you probably are not overclocked, and running at the stock specs for your CPU. Probably not going to be the solution for all, or even most for that matter. Was just sharing in case anyone else thought their OC was stable just to have NW prove them wrong. My previous OC was rock solid in WoW, DayZ, GTA, basically anything I threw at it… NW seems to make much better use of multithreading, and pushed all cores/threads of my CPU extra hard, none of the others taxed more than 3-4 cores at a time in my experience.

I final got some sort of crash error when I tried booting the game.

image

Its a DMP file so I couldn’t look, I tried opening with WINdbg but I’m not sure what to look for specifically where it’d tell me what the source of the crash is.

1 Like

So I finally got it to work, with the worst way possible.

We factory reset the entire PC and now it works

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.