Declare war bug :(

4+ companies pushed Reek tonight on my server, only 1 could declare (one of the smaller ones)

This is so embarrassing for AGS

1 Like

When our guild pushed the 90% we had another guild come in and help us for the last 10%. The only thing we can think of, is that guild was the last one to turn in the finial quest that threw the territory into conflict. They were the ONLY guild that was able to declare war, and they did less than 10% of the contributions. We had 3 or 4 hours invested for 90%+ and couldn’t declare. Makes us hesitant to try again.

Server: Xibalba
Company: The Squad
Territory: First Light
Pushed 90% of the conflict. We are a Syndicate company. Took us about 3 or 4 hours to push this from 0 to 100%. Put into conflict on December 4th @ 745pm EST. As you can see from the screen shot, Governor and Consolers are unable to declare war. Governor is Sr Normous, myself the consul Zulance & Isard Ysanna are all unable to contest this territory. Another company who turned the quest in last did less than 10% help and were able to contest the territory. Help or compensation for this would be appreciated.

Hi, we have found an issue with how influence contributions were getting counted. We found out that some updates could be lost and not counted at all. That issue was causing some companies to not be eligible for the vanguard, even though they had contributed much more than the required influence. The bug is now resolved. Please let us know if you encounter any further issue with declaring war in this thread and we’ll investigate further. If you do, please provide all the necessary info. We are sorry for the inconvenience that bug could have caused.


I can’t even imagine how many things are not working as intended and, as a result, people are just wasting their time doing things in the game.

1 Like

not the issue that we can´t declare war, but we can´t get passt the wallet selection. when hitting the final button the walletselection just opens again.

two months to fix an issue that devastates the heart of the pvp game and a fundamental game mechanic.


Also, I highly doubt this is “we have found”. AGS didnt find this, multiple people have been reporting this for months. Despite the multitude of reports, this appalling bug wasn’t even placed in the “Known Issues” list.

How about compensation to all the companies that were affected by this, including my own, twice.

AGS say they track everything: well then they should know how many hours and hours we grinded out the pvp faction missions, only to have this error render worthless everything we have done. Our company lost 25% of our active players JUST BECAUSE OF THIS BUG.

Amateur Games Studios.

1 Like

Same. Our company on our server has failed to declare on Mourningdale 9 times since launch, either because of this bug or other ones (I believe the others have been patched at this point). It’s a huge waste of time


When you think it can’t get any worse.

You have a laundry list of bugs but God forbid you miss a cash shop content drop to fix the game.

It is painfully obvious how little care is given.

You cherry pick responses ignore valid ones and say people are being hostile. No your game sucks and the sheer lack of professionalism is shocking. You get what you give.


Can you explain what the bug was and how it worked? Is there anything we can do in the mean time to work around it?

We have easily lost 60 hours (no exaggeration, probably undercutting the real number tbh) running as a company against Zerg companies, and that is per person, not total for the company, which has caused people to quit.
This was raised by probably over 300 people since October. If there are 100s of people reporting something it may be worth investigating it instead of stating in the dev blogs that this isn’t an issue.
When was this resolved, because the issue was encountered again on Sunday/Monday this week?

It’s good to see the Dev Blog was edited, because previously it said that what everyone had been reporting wasn’t true. Progress!

How about compensation for the lost time and lost territory? We would have 100% taken the territory, instead another company took it! Server merges are coming soon and the reward for owning those territories is rumored to be 50k gold. Not to mention the weekly revenue our company is losing out on. That seems fair for our lost time and lost territory.

U.S. East Nunne
Company Name: Technomancy
Territory: First Light Twice and Ebonscale
Approximate time: 29 November through 09 December

Our company put in well over 10%, We worked with other teams, but we put in more. We could not declare, but they could.

This needs to be fixed.

Server: Duzakh
Company Name: Little Herb
Territory: Ebonscale
Approximate Time/Date: Faction influence reached 100% on 8th December 2021 between 5:00 SGT to 8:00 SGT. However, there was a scheduled invasion that is going to occur during the downtime of the new patch update on the 9th of December. After the new patch update, we were unable to declare war and I am sure my company contributed more than 20%.

I speculate that the influence that my company has contributed before the Invasion was announced was not counted (Invasion UI did not show up). To further elaborate, we pushed the influence from 9% to 26 %, thus contributing more than the minimum 10% required. After an incoming invasion was declared, the faction influence was then filled up to 100% and another company was able to declare war.

Server: Zugen
Company name: Machine Works
Territory: Reekwater
Approximate Date/Time: Influenced reached 100% 12/21/2021 around 11PM central time, we were not able to declare war because of an invasion. Invasion ended approximately 8:30 PM central time 12/22/2021, but we are not able to declare war still after 30-45 minutes. We ran approximately 30% of the influence bar as our company. It appears no other company is able to declare yet either.

Server: Krocylea
Company name : The Last Remaining Few
Territory : Mournngdale
date/time : 12/27/21 5:20 mountain time. Company did WAAAAY more than 10% influence. Best guess 30%. Our declare war button was greyed out and stated we did not do enough influence to declare war. Literally worked on this as a company for several hours. However a company by the name of “the cops” was able to declare.

Aeternum Odyssey
Cutlass Key
15-01-2022 - 21:00 - 22:00 PM CET

  • What is your character name in New World: Berserk3r
  • What server/world did you experience your issue on: Caer Sidi
  • Describe the issue you are experiencing: Pushed CK influence before a invasion started, after it finished declared the war as you can see in the pictures, right after it ANOTHER Invasion started in CK and we lost the war declaration and the money,
  • Is this a bug or an exploit: BUG
  • (if a bug) How did the issue effect your gameplay: LOST TIME and money
  • (if a bug) Were you able to recover from the issue: NO
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:

After the second invasion in the row i was ABLE to declare again and went to war

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.