Declared war - no one can sign up and took 15,000 gold from company

  • What is your character name in New World: Reform
  • What server/world did you experience your issue on: Yaxche
  • Describe the issue you are experiencing: When anyone in the server is in Cutlass Keys, the fort and influence % stays the same and does not update. However, if you are anywhere but Cutlass Keys, you will see the most updated fort information and influence %. We worked around that and my company - Old World Imperial Bank worked hard to raise influence in Cutlass Keys territory and then declared war on the territory after the system taking 15,000 gold from our company bank. Then after successful declare, no one in the server can sign up for war as the board is greyed out the moment we enter cutlass keys and it shows that the territory is not being declared war on. The war is scheduled for tomorrow, Oct 27 at 7:00 PM ET and no one is able to sign up.

This is not the first time we have encountered a glitch declaring war. Last time, we encountered a bug where we lose our declaration due to corruption invasion. A lot of people are frustrated and I know people from my company the server has quit the game due to putting a lot of effort and losing it. I understand the dev team is really busy fixing a lot of issues but I hope any Dev who reads this can please take a look and try to fix the situation. I know this may not mean a lot to you but we worked hard in this game to put the time and effort to increase influence and saved up hard-earned gold in a dwindling economy. It really sets us back a lot and we hope if the war doesn’t happen we at least get our money returned to us.

  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Several companies, game play time from players server wide, lost 15k from the company bank due to this bug and 10k from the previous bug.
  • (if a bug) Were you able to recover from the issue: Nope, money is gone and all the effort over days bringing influence to 100% to get war declared
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: Available upon request
  • What are the steps to reproduce the issue as you experienced: This issue itself is the first time we have experienced where when I am in the territory, it doesn’t update the current status of the declared war and fort status.

Dev Team: Please try and fix these war bugs for war tomorrow and refund our money.


Good luck ! You will receive your refund in 324 business days

I’m a member of this guild and can confirm the issue is present.

here’s a screenshot from monarch bluffs.
Here is a screenshot in Cutlass keys at the war board:

1 Like

I made two videos of what it shows on our side.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.