Dungeon finder for tempest missing

tempest dungeon finder icon does not show up on map, all other dungeons do. Basically impossible to complete the story quest for tempest keep because it’s relatively old content and nobody is grouping for it in chat. Stuck on progression for more than 3 weeks now.

forgot to say yes i’ve done all the common non-issues that are going to be asked of me–reinstall game, check validation, etc. ITS NOT SHOWING UP ON THE MAP and it’s impossible to even get to on foot without a group, which nobody is doing.

Hello @Crazim,

Welcome back to the New World forum, I’m really glad to see you are here at the forums and hope you can enjoy your time here and at the game as well!

I’m sorry about the issue you’re having with the Dungeon Finder icon at the map, since you have tried all the basic troubleshooting as you mention in this case and due to the nature of your concern I can recommend you to reach us via player support using the following link: Contact Us | Amazon Games to create a support ticket and review your case in more depth.

Please make sure to add the DxDiag and Gamelogs through a sharing link from a Cloud Storage like Google Drive to the support report, you can pull it following this steps:

DxDiag report:

  • Go to Windows Start search bar and type dxdiag.
  • Click on dxdiag.exe.
  • When green progress bar goes away, select Save All Information and save the file to their desktop.

GameLogs:

  • Game logs can be found on: \Users\USERNAME\AppData\Local\AGS\New World\CrashDB\reports\

If you need further assistance in any other issue please don’t hesitate in reaching us again!

Cheers!

i mean if literally every other facet of the game is working just fine then why would i need a dxdiag to troubleshoot a missing icon for a dungeon that isnt accessible with a group finder icon? all i need to know if this is by design or if you need to complete the main questline to unlock the dungeon finder for it or not.

Hello @Crazim

Hope you are doing great and apologize about this misunderstanding!
This may not be a glitch or something for your map the icon that you are looking for is unlocked on the map once you have visited the site you will need to make your way to the “New Myrkgard Shrine” I understand this path is callenging since is full of corruption. Even though you can skip this quest and take your way to Brimstone Sands and come back to defeat Isabella later!
If for any reason you have already visited the shrine and the icon still not appear please contact the support as was suggested.

Best wishes adventurer
Keep gaming!

Just wait until the Merk chest runs, then peel off from the zerg. You can make it to the fast travel pad in light at 300 con.

U have to personally go there to see the icon

Thanks all! this answered my question.