Error-Unable to establish connection to server

Started this morning having this error and could not get past it. I have tried 2 different networks, restarted PC, different servers and still unable to connect. I had this issue on launch day but it was fixed and have been able to play with no issues till today. My husband also had the issue this morning on his PC. Anyone have any other suggestions?



I’m sorry to hear what is happening to you.

Please try this.

Resolving this issue will require allowing or adding ‘newworld.exe’ to your Firewall.
If you do not have 3rd party Firewall software installed, this can be added via Windows Defender using the following steps:

  1. Select the Start/Windows button > Settings > Update & Security > Windows Security and then Firewall & network protection.
  2. Select Allow an app through firewall.
  3. Look for and select ‘newworld.exe’ in the list of installed apps.
  4. Select OK.

Once added, try relaunching the Game again and confirm you are able to play without error.

I run the game through Steam, the exe does not come up in steam unless I am not looking in the right stop. I have McAfee and have turned off the firewall and still unable to get in.


It doesn’t matter if the game lunch though steam, what steam does is execute that .exe to make the game run. So please try to do that.

Also if that doesn’t work please check this too:

  1. Restart your PC and disconnect the power to your Modem and/or Router for 60 seconds.
  2. Reconnect the power and wait for the internet connection to be restored before powering your PC back on and attempting to access the game.
  3. Try switching from a Wireless connection to a Wired one (if possible).

If that doesn’t help, we’ll need to completely reset and refresh the connection your computer has to the internet:

  1. From the Start menu, begin typing ‘cmd’.
  2. In the results that populate, right-click the Command Prompt result and select Run as administrator.
  3. Type ipconfig /flushdns and press Enter. Wait a few seconds and when the command prompt appears, proceed to the next step.
  4. Type ipconfig /registerdns and press Enter.
  5. Type ipconfig /release and press Enter.
  6. Type ipconfig /renew and press Enter.
  7. Type netsh winsock reset and press Enter.
  8. Restart your computer.

Unfortunately still not working. Found the newworld.exe and added that also.

Ok, let’s try this:

  1. From the Start/Windows Menu, select Settings.
  2. Select Network and Internet.
  3. In the Status section, under Change your network settings, select ‘Change adapter options’.
  4. When the Network Connections window opens, right click your network connection.
  5. Select Properties.
  6. Scroll to Internet Protocol version 6.
  7. Uncheck the Internet Protocol Version 6 (TCP/IPv6) box.
  8. Select OK to save your changes for the selected network adapter.
  9. Try launching the game again.

Should you still encounter this error and are on a Windows Preview Insider build, please roll back to a stable build of Windows 10 as we are not currently supporting Insider Builds during our Alpha testing.

Oh well guess I will just wait it out longer or go back to playing another game since I am not on a Windows Preview Insider build that I am aware of and nothing is working.


Something to try is using a different internet, for example, my home internet Century link using their provided box works just fine, so does my phone internet (hot spot) But using a MiFi M2000 from T-Mobile does not work and gives me this error. from what it seems like to me this problem might have to do with what (router or Modem) you are using might be causing problems, i know this was 8 days ago but give it a shot using a different internet source, don’t just do just 1 , attempt 2 or 3 different internets if you can, like using a friends internet at their house if you own a laptop or downloading it on their computer and seeing if that fixes the problem. Btw for my internet my Internet Protocol Version 6 (TCP/IPv6) box is checked (turned on) please let me know if this fixes your problem i would love to know.

Yes I can connect via my phone hotspot but not through my ISP. We have Century Link but it is DSL connection so maybe that is the problem, that is the only thing we can get out where we live. Not sure if getting a new modem would help or not but might be an option to try and see. Just seems odd that we have been able to play just fine until they did something with the game via patch day. Thanks Shiro for the advice at least I can play some! Wonder if it will still be usable when my hotspot 5g runs out or not. Guess we will have to wait and see.

hi sorry for late reply, my Modem is C1100Z, now while i have that modem i bought a gaming router I’m using to connect and play the game because the modem they give you is CRAP for wifi, but using a router gives me 30-60% faster speed… Also i got it at bestbuy for around (170$,) not sure what it is as I’m not home (2 more days) but i can let you know as well as connect to my modem and not router to see if it works from that as well. (note the modem they give you is a 2 in 1, a modem and Router package) Also not sure if i got DSL or Cable, my internet max is 25MB for my town of 480 people…
Also to note when i get home i will be installing Starlink internet so i’ll will you know how that works as well. but this does seem like a problem with the Modem as my friends have some what the same problem when using their modems not hotspots… i will be trying to dig deeper on this problem as Amazon is not interested in fixing this. unless @Zaphkiell or any of the other customer service team wants to send this information off to the Tech team to help fix this problem.

Regarding your internet on your hotspot, you should be fine unless you don’t have unlimited 5G hotspot (limited 256KBS when you max your limit) i always max mine but the town i live in, no one uses the tower so i never have to much of a problem, :smiley: 400+GB used in one month on hotspot FTW.
anyways i will let you know how everything goes.


I’ve got the same issue.
I can connect to other servers like Icaria but when i try to connect to Petermannland i get that messege.
Any solutions since it’s clearly nothing wrong on my network since I’m able to play on other worlds.

I’m having this issue as of right now, and none of the support persons steps fixed it…


Same here. Has never happened before, only after patch, so it’s not an issue on my side. Can’t get into the game at all.

1 Like

Same here, did not have any issues before the patch…

Same here for the first time after the new patch 1.0.4.
But first workaround (allow in Windows Firewall) fixed it for me.

Yeah mine is allowed on the firewall but no fix in my case. Patch messed it up…

I found a possible fix, I verified the integrity of the game files on Steam and now it lets me log in to server.

1 Like

This worked for me too! Thank you so much.

This was the first thing I did on my own before taking a look into the forum, but didn’t help without adjusting the firewall.