Error-Unable to establish connection to server

Regarding my post before. Starlink internet worked Perfect! only had 60MB internet in my location but its better then my normal 14MB lol…
Also the CenturyLink modem/router did not work for me but hooking my own gaming router to the the modem worked just fine.

i would also like to give information to people playing on (ANY!) T-mobile Wifi hotspot.
If you are getting the message for this topic, you just half to change to B2B.mobile.com and Lock it into IPv4
it is slower in some cases but it also does fix the (No Route) for your discord voice calls and lets you join new world without any problems. @Zaphkiell please Add this and the others to one possible fix for people under a pinned

Fix #
1: different router (to find out if this is the cause of your unable to connect error, please try a different router, not a combo modem/router, you can also try your friends router at their house to route out the problem.
2: your phones hotspot can be a temporary fix to the problem until you find out what your problem is from the steps made.
3:Phone Mifi hotspots (referred to as mini modems) like t-mobiles M2000 mifi. please change to B2B.mobile. if on T-Mobile and Lock it into IPv4, it might be a slower connection for some people, please note the normal Fast.t-mobile. has been having problems for people since around the June update to to m2000 devices.
4:Adjusting your firewall??? maybe @TheRealFitti can explain what he did for this fix if it was a fix
5: Verified the integrity of the game files on Steam is one fix for people Ralervs said it worked for him.
6:Restarting your steam and closing out the game. (if you lost internet and you are getting this error, restarting steam and the game has fixed this problem for me on hotspots)
7: there are other fix’s stated by newworld all over the web, if you come a crossed this page. maybe one of the fix’s we did here that worked for us will work for you too.

This problem still annoy me. I have to re-login several time . So frustrated
this problem occur after 1.0.4 patch .
any suggestion or vpn?

i have the same problem and tried every thing you said and still not working and i haven’t even try the game yet just create the character and disconnect from the server due to the error this become the worst game i have ever bought in my life

Bump.
I am fed up with Amazon not taking this issue seriously.

I have this error notification.
I have another user in the same house that is able to connect to the same server fine. We are both using wired connections to the same router. We have both been able to play at the same time since release day.
I first restarted my computer and was able to play; but, after closing the game and restarting some time later, I receive the same error again.
I have restarted again. Verified game integrity. Allowed in firewall. IP released.
I am currently re-installing the game.
Any ideas

My wired connection went down, and now I’m using my phone as hotspot and having the same problem …

Tried verifying integrity, resetting and flushing dns, restart computer etc …

I’ve gotten it to work a couple of times by changing realm back and forth and then pressing refresh and then “play” … but no luck recently … I’ll keep you posted.

Are you going to do something about this error? 30 days and on, one time you can log in without a problem, another time for 1h I have to press play to see the message “Unable to establish connection with the server”

1 Like

amen

1 Like

Is this game really made by amazon? the company that alot of games use its servers?

same problem . and no solution is working . and i cant even refund the game because i spent more than 2 hours trying to fix this .

I have the same error since last update. Already tried everything written above. Only thing that helped is vpn but i don’t like to use it. Any other suggestion to fix it?

Same error since the new patch. Fixes do not work. Very frustrating because I really wanted to try out that new void gauntlet D:

This Patch fucking broke my game I either can log right on or cannot log on at all, and if I can get logged on it will randomly crash for no good reason. All my drivers are up to date do all these troubleshoot steps, and then the help is no help at all because they talk to you like you don’t have a clue and would not have tried all these steps before. I am at over 650 hours with no issues until this update 1.1.

1 Like


Nice very NICEEE

still the same shi *
Can you do something about it?

I always have this same error.
What I do.
I close the game, run in cmd the command: ipconfig /flushdns and then reopen the game.
Sometimes i need run /release and /renew command to, reconnect my modem is a terrible thing.

I don’t know why every time I need do this.

Please for the love a GOD fix your servers and their connection issues. I still have this problem all the time. I can get on and play for a few hours, but if I exit the game I get the same error every time and have to try and restart my PC or flush the DNS. We should not have to this every time to play a game and you need to get your sorry connection/stability issues fixed ASAP.

Literally just did a flush and pc restart and couldn’t get back on main character. Then tried verifying the game files through Steam…that did not work. This time after logging on to second trash character and logging back to main menu then to main character was I able to get back on. Not sure if it may be the issue but are your servers actually logging our characters out of the server when we exit the game?

Same problem.

I’m on US West with my 60 character. Played for 300+ hours without issues. Today suddenly while playing everything froze, I got “lag detected” message and it kicked me out. OK, I thought server died. Trying to go back in I get “unable to establish connection with the server”.

But I can switch regions and login to my trash level 3 without issues!

What the hell?

1 Like

None of this is the solution.

I can login to one character but suddenly cannot login to another. So clearly the problem is not on my end but on your server.

1 Like