Expedition Bosses not Increasing HWM

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: Tymazen
  • What server/world did you experience your issue on: Rosetau - US East
  • Describe the issue you are experiencing: Expedition bosses do not drop HWM increases, at all.
  • Is this a bug or an exploit: Bug
  • (if a bug) How did the issue effect your gameplay: Not worth running them.
  • (if a bug) Were you able to recover from the issue: No.
  • (if a bug) Please include a screenshot or video of the issue that you have experienced: N/A
  • What are the steps to reproduce the issue as you experienced: Do any expedition while tracking your HWM.

Details:
Over a dozen runs each in gen/laz, not a single HWM increase. Jewelry still all 520, armor still all 591, weps still still 570. No changes, at all.

These orbs take a TON of gold and time, you specifically posted they guarantee increases, why aren’t they?


As you can see, I keep track of my WM.
I do confirm that’s sometimes in Genesis I get 1 bump or 2 bumps. And I run a lot of Gens. We have 3 bosses AGS. Hope next update fixes it. No point for me to run Genesis or Laz what so ever

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.