Expeditions not working currently?

Hi guys,

we just tried to enter Lazarus, NW showed the loading circle and a few seconds later we were back at the entrance, the key was lost :confused:

Is it a new bug or what’s going on??

Server: Evonium

Regards,
DocFraggle

Edit: according to other players other expeditions seem to work, afaik it’s only Lazarus currently

Edit 2: some people said relogging would return the key to the inventory, that didn’t work for me. + I can’t fast travel because of “You can’t fast travel while in an encounter”

Edit 3: restarting the game completely worked, the key is back

log out → character menue → refresh → log in → key back in inventory

Thanks, that way it’s faster :+1:

Still strange…

Hey there DocFraggle, while I’m glad to see you were able to find a workaround to your problem, make sure to keep us updated on the forums if this happens again!

@Centeotl thanks, I will! Btw, lots of other players had the same problem

Thanks for letting me know! A higher sample size will help our developers look into this.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.