Explosive Arrow and ALL AOE Abilities absorbed

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here

To report a player or company for Code of Conduct violations, please do so here

  • What is your character name in New World: Montaine
  • What server/world did you experience your issue on: Valhalla
  • Describe the issue you are experiencing: Explosive Arrow explosion is not triggering all the time. When testing with target dummies, the explosion doesn’t trigger at all. The damage also appears to be off with the Explosive Arrow making it seem underwhelming. I am currently specced into where the explosion should deal 170% weapon damage; yet, it is dealing less damage than my Penetrating Shot. Penetrating Shot is 150% weapon damage, so I’m not sure why it is dealing more damage. When running an M10 dynasty expedition, the explosive shot was not exploding when shot at mobs. It is not just an issue shooting at target dummies

This is not just an issue with explosive arrow either. Poison Shot has the same issues with not detonating. Orb of Protection, Beacon, Gravity Well are going through the floor and being absorbed by the world. Explosive Arrow detonates when hitting the ground, but if it hits an object or say the ramparts or wall around a fort, it does not detonate.

  • Is this a bug or an exploit: Bug

  • (if a bug) How did the issue effect your gameplay: Makes the ability not worth using

  • (if a bug) Were you able to recover from the issue: No

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
    https://youtu.be/pDQ_XIwkesg

  • What are the steps to reproduce the issue as you experienced: Test with target dummies

  • When did this happen? (Date and Relative time; please include your timezone) 7/28/2022

1 Like

bump

bump

bump until I get a reply from AGS

bump

bump

Similar issue with other player created/conjured ‘items’.
Gravity well’s disappearing, sticky bombs disappearing.

Beacon is disappearing on Wall or Floor

+1 for experiencing both Exp Arrow explosion not happening (or just going right through mobs) and Beacon/Orb not triggering

I’ve noticed the same thing with poison shot as well

@Developer

I want to make sure this bug report is investigated please. We have multiple people experiencing the same issues with multiple AOE abilities

New World Explosive Arrow hit box?? - YouTube perfect video highlighting is as well that i recently watched. how does this come out of ptr??

i really hope this an every weapon issue so its fixed faster. if it was just a bow issue, we would be stuck with it for 1-2 months

All I want is for someone from AGS to watch the 60 second video and just tell me whether or not they are aware of the issue

In opr last night somebody tried to hit me and i evaded the shot, only problem is I don’t use a rapier lol. Full evade emotion, was pretty solid

bump

5 days and no response from anyone at AGS. Still having this issue

@Community-Team

bump

@Developer @Community-Team

  • Fixed an issue that caused several weapon AoE abilities to not cause damage when impacting against terrain.

Explosive arrow still not exploding when impacting objects. I just tested again, and this is still an issue

this is a joke explosive arrow is a buggy mess

1 Like

bump