Extra conqueror's cunning disrupting salvaging and other game actions

  • What is your character name in New World: QuietPhoenix

  • What server/world did you experience your issue on: Valhalla

  • Describe the issue you are experiencing: Every salvage, box open from inventory, I get a bunch of extra conqueror’s cunning (up to 6). However, they’re not real; they don’t go into my inventory. It’s quite annoying because it slows down salvaging dramatically. The issue has persisted after restarting the client entirely.

  • Is this a bug? Yes. Since the items are not actually put in inventory, it’s not an exploit though (but until I saw they weren’t generating items, I thought it’d be a potential exploit).

  • (if a bug) How did the issue affect your gameplay: It’s making it take several seconds to salvage each item. This is miserable.

  • (if a bug) Were you able to recover from the issue: No. Please help.

  • (if a bug) Please include a screenshot or video of the issue that you have experienced:



  • What are the steps to reproduce the issue as you experienced: Not sure, but I was doing a relatively unusual thing of opening a couple hundred crates from inventory

  • When did this happen? 1015pmCT Oct 26, 2022

Known issue.

While it is a UI issue, how do I get it to stop? I’m stuck and encumbered and it’ll take a long time to salvage my gear because of it. Let alone salvage as I resume normal activities.

After logging out for the night and returning the next day, the UI bug appears to have resolved, so I’m no longer stuck.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.