Falmea's Wrath Quest Bugged

Server: Barri - Char Name: Pico

Today i tried to do Falmea’s Wrath several times, after gathering all items i go to an arcane shop and craft Falmea’s Wrath Fire Staff but then the quest doesnt recognize it being done. The quest asks to visit an arcane shop and sometimes it checkmarks that as done other times it doesnt, the fire staff never did tho. Tried to speak with the NPC that supposedly completes the quest anyway but didnt work as well.


image

as you can see in this images.

Can’t abandon this quest, only reset.

This is a known issue and they are working to fix it.

1 Like

oh is it the same?

i can’t remember where i’ve accepted it but the materials to gather is in Edengrove, mourning dale and restless shore, to deliver in weaver’s fen.

Yes it is. The item id is setup incorrectly on the quest, they have to fix it :slight_smile:

1 Like

alright, cheers.

It’s getting fixed with tonight’s update: New World Update 1.7.1 - News | New World - Open World MMO PC Game

i have the same problem. i just get the matts and craft the item but the quest still in craft the staff

It’ll be fixed after the update finishes tonight: New World Update 1.7.1 - News | New World - Open World MMO PC Game

The patch didn’t fix the issue because I still got it.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.