Fast travel broken

****** Please make sure you fill out the following information before submitting a report ******

Don’t forget to check the Known Issues List to see if your issue is currently being worked on by the dev team.
We also have existing workaround for some issues that you can find here:

  • What is your character name in New World: she’har
  • What server/world did you experience your issue on: lagado
  • Describe the issue you are experiencing: visited reekwater and ebonscale and both places did not register as me having visited so can’t teleport back. And they also do not register as being in a town so can’t even teleport out.
  • Is this a bug or an exploit: bug
  • (if a bug) How did the issue effect your gameplay: can’t travel
  • (if a bug) Were you able to recover from the issue: still broken send help
  • (if a bug) Please include a screenshot or video of the issue that you have experienced:
  • What are the steps to reproduce the issue as you experienced: i used the unstuck option. I tried reentering multiple times. I tred using the shrine manually. I tried reducing my weight to 120. I tried relogging several times

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.